Clutch chattering on 2007 XL

Discussion in 'Transmission' started by perzaklie, Sep 11, 2009.

  1. perzaklie

    perzaklie Member

    34
    6
    0
    I bought this bike with only 204 miles on it. The clutch chatters really bad sometimes unless you really get on the throttle and slip it. Is this normal or do I have a problem? It now has a little over 5,000 miles.
     
  2. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Personally, I would want to pull the primary cover (derby cover and cam chain inspection cover as well) and eyeball the condition of the fluid. When you drain it, make sure you use a clean container so you can check to see if it is pale amber (as it should be), brown or going to black, and smell should be like plain gear oil, no roasting almond or stong burnt smell, measure amount of fluid taken out (approx. 1 quart)...was it run DRY?, what deposits are lying in the bottom, (should be none) and how much metal filiigs drain plug magnet collected (very little). Maybe someone even put the wrong fluid in, like ATF/Dextron...but at least you will be able to determine visually if everything in there is fine.
     
    Last edited: Sep 12, 2009
  3. glider

    glider Veteran Member

    25,464
    108
    44
    I would do a service on the fluids and ride it a bit. Chances are it could be needing a service and that is causing the chattering. Who knows what oil is in there if you aren't the original owner or even if it has sufficient oil.
     
  4. perzaklie

    perzaklie Member

    34
    6
    0
    I bought it used at 207 miles. I had the HD dealer perform the 1,000 mile service and it started after that. It's due the 5,000 mile service so I will wait until it's done and see if it helps. I will have it done by my regular shop this time.
    Thanks all.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
    Check to see if they put the oil in that they were supposed to in the trans/primary and it's at the right level.