Check engine light

Discussion in 'Electrical' started by kpstar212, Apr 19, 2011.

  1. kpstar212

    kpstar212 Member

    50
    0
    0
    2004 FXDLI. When cold I start bike up and engine light goes out. Comes back on then it flashes off and then back on again. Ride down the road a mile or so and after bike warms up light goes out. If I stop and restart with the engine warm. Light comes on for few seconds and stays off. Does n't make sense to me. Other than that bike runs just fine. Any ideas. Haven't tried running codes yet. Sort of hesitant as I am familiar with electronics.
     
  2. Hoople

    Hoople Account Removed

    7,198
    0
    34
    As the code shifts from a "current" code to a "historical code" that will be normal to see. Lets say the lite is solid ON. It means there is a current code that is not intermittent or will not correct itself. But if the solid lite was to go out, it means the current problem was able to correct itself and is no longer a current code but it's now a historical code.

    Part of what your seeing is a simple bulb test during ECM boot. Then it comes back on & off to tell you that you have a stored historical code. Then it comes back on solid to tell you that you just flagged a Current code. Then it goes back off because the problem happen to correct itself somehow and the code just shifted from a current to historical code.
    It all makes perfect sense when you think about what it is trying to tell you.

    Just follow the steps in the link to extract the codes.

    04-07 HD DTC Codes and Activation - Archive - Harley Davidson Community
     
  3. kpstar212

    kpstar212 Member

    50
    0
    0
    Thanks,
    my post should have said unfamiliar with electronics. Should I disable the headlight when checking codes to prevent battery drain since the headlight will be on will I am attempting this ?
     
  4. kpstar212

    kpstar212 Member

    50
    0
    0
    Got it. P0118 code. Chart says ET sensor High. Now what is an ET sensor and what is my next step. Also I couldn't get it to clear.
     
  5. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Did you follow the procedure in the link. It should have cleared.
    As the link states, ET means engine temperature sensor..
     
  6. kpstar212

    kpstar212 Member

    50
    0
    0
    Tried a couple of times. will try again. Only faults when starting cold engine. Then goes out. Is sensor going bad ?
     
  7. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Since it is a current DTC when cold and a historical when hot, the thermistor in the sensor is probably open when cold. I would meter test it when cold. If the resistance is way out of range the ECM software will probably flag it as bad. There is a temp vs resistance chart in your service manual that will help you determine where you stand.

    For example, the temp sensor on my 2009 should be about 2200 ohms @ 86*F and 175 ohms at 210*F. That is a big swing and should stand out if incorrect. (don't know if your temp sensor is same)
     
  8. kpstar212

    kpstar212 Member

    50
    0
    0
    Got to clear. I really appreciate all your help. I am learning a lot.
     
  9. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Us FXDL guys have to stick together!:)
     
  10. kpstar212

    kpstar212 Member

    50
    0
    0
    Don't have a service manual yet. Do you know off hand where the sensor is located ?