carb trouble

Discussion in 'Engine, Fuel and Exhaust' started by hdpipes, Jul 10, 2013.

  1. hdpipes

    hdpipes New Member

    1
    0
    0
    I recently had the cams done on my 2003 roadking and the bike is running ok but not 100%the shop is trying to resolve this sputtering issue they have replaced the carb body we have a keiun cv carb on the bike with 185 jet not sure what the slow jet is but when the bike is idling it is great when I go to take off the bike spits and sputters when I get to a light or down shift and give it a shot of fuel it sputters and runs poorly but when I get on the highway and slowly give it throttle it goes along fine except for half way through the throttle is a bit of a delay.if I hit it hard it bogs and sputters hard I am stumped.these guy's are workin to help me but thought I would see if someone on here had some suggestions.
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Which cam did you put in? What AC are you running? What type exhaust are you running? Any baffels? Any spacers on the needle? Why was the carb body replaced?
     
  3. Slo-Ryd

    Slo-Ryd Junior Member Contributor

    487
    28
    18
    First thing i would have them do is remove the air filter and cover and with the bike running give the throttle a quick twist to make sure the accelerator pump is giving a good squirt down the throat of the carb. The nozzle is a brass tube in the 5 o'clock position that sticks up about a half inch or so and can be turned carefully to aim the shot of fuel down the throat. If it is spraying a healthy dose, next continue giving it twists and watch the slide in the middle and make sure that it is rising and falling with the throttle twists. If that is good, while idling spray some WD40 around the intake to cylinder head gasket flanges and watch for any change in idle which would indicate an intake leak. Ideally this should be done from the horn side to minimize any spray getting sucked in from the throat side if the air cleaner is off or just do it with the ac reinstalled if the other things check out ok.

    No squirt = bad accelerator pump diaphram
    No rise in slide = torn or pinched slide diaphram
    WD trick = intake leaks

    Let us know what you find after checking these three areas and we can help diagnose it further.
    [​IMG]
     
  4. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    Also possible is the slide diaphragm has a leak and the slide does not respond properly. Has the slide vac. hole been drilled? Possible it was overdrilled and is letting the slide raise too fast.
     
  5. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,278
    133
    157
    See previous 2 posts and that about covers it

    Brian
     
  6. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,316
    73
    130
    Yep, what they said.