Bucking Lowrider

Discussion in 'Dyna Models' started by lowriderfrf, Oct 10, 2011.

  1. lowriderfrf

    lowriderfrf Member

    57
    18
    1
    Just got back from a 700 mile run from Orange County, CA to Big Sur. Great ride but a little cool and some early morning fog this time of year. Just outside of San Luis Obispo on Hwy 101 at 75 mph the bike bucked pretty hard. Felt like a huge misfire. A couple of miles later it did it again. I noticed both times that the speedometer fell to about 20 mph even though I hadn't slowed hardly at all. Pulled into San Luis Obispo to try to diagnose the problem. Seeing that I apparently lost all electrical and remembering that I replaced the battery a couple of weeks ago, I started there. Sure enough the screw on the negative terminal backed out about three turns. Tightened back up, and went the last 400 miles of the trip without another incident. It would have been easy to blame bad gas, ignition or other problems. I posting this so if anyone else has this come up and notices the speedometer needle fall quickly, check the battery first. I could have spent hours looking for another reason for the issue. I'll probably put a little locktite on those terminal screws this weekend.
     
    1 person likes this.
  2. blueglide

    blueglide Member

    59
    0
    0
    I had a battery earth lead problem on my 2011 streetbob. The connector tab on the earth lead is 90°. It had cracked right on the bend and finally gave way cutting the motor.

    I was not far from an auto parts store so I was able to make a repair.

    A spare battery lead tab is now in on bike toolkit!!!

    Never hurts to pull the battery cover and have a looksee now n then I reckon-I didn't do that on this bike as its new and had just its first service (doh!-I know-cue Jim Diamond song- I shudda Known Better).

    Good post, glad ya found n fixed it.
     
  3. gator508

    gator508 Senior Member

    2,308
    68
    81
    Lowriderfrf,

    Had same problem with my sportster and then softail. I would not recommend locktite, I put star lock washers on, no problem, the connections stay tight. I do check them now every once in a while.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Very good advice here, I would add some dilectric grease to the connections to keep them corrosion free and water proof:s