Brake lights

Discussion in 'Dyna Models' started by Renegade946, Nov 11, 2012.

  1. Renegade946

    Renegade946 Member

    5
    0
    0
    I have a 1995 Dyna Wide Glide. I replaced the rear tail/brake light years ago with one that flashes 6 times and then stays on until I take my foot off the brake pedal. I also have aftermarket tail/brake/turn signal lights that I also installed years ago. These lights also flash 6 times when brakes applied. I rod it yesterday and the guy that I was riding with said that my brake lights were really dim. I checked it and the tail lights are dim and so are the brake lights. The headlight and front running/turn signals are bright and fine and don't dim when the brakes are applied. Could someone please advise me what the problem is. They have worked fine for years and now they don't. Thank you for your help.
     
  2. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    I have seen quite a few taillights that leak and get very dirty inside the lens. It's only 2 screws to remove, then you can eliminate possibilities 1 by 1.
     
  3. cdn-bigfoot

    cdn-bigfoot Junior Member

    645
    26
    1
    I put an LED taillight on my Streetbob a few years ago. Very bright and a low profile smoke lens really suited what I was going for with that bike.
     
  4. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,279
    133
    158
    It may be a corroded connection or ground only affecting the rear lights there should be a plug and socket under the seat where the rear wiring loom plugs in i would start there

    Brian
     
  5. r_k_dragon

    r_k_dragon Active Member

    270
    0
    4
    I'm with Brian. Check the grounding side for corrosion and tightness.
    [​IMG]