Are you having any problems with your '07 Harley

Discussion in 'General Harley Davidson Topic' started by SteveB, Jun 15, 2008.

  1. SteveB

    SteveB Member

    70
    16
    0
    I am completely satisfied with my '07 ECG...No problems after 16,000 miles:D. How satisfied are you with your Harley-Davidson? Are you experiencing any problems? Are you happy with your motorcycle???
     
  2. DYNAGUY

    DYNAGUY Active Member

    123
    26
    0
    TICKLED TO DEATH with my Wide Glide. NO problems. Just had to put loud pipes and open air intake. But just about evertone does that. Not been one issue with it.
     
  3. Tigg

    Tigg Junior Member

    618
    28
    2
    I love my RKC as far as feel ride and power the only gripe I have is the primary and tranny noise because of the new compensator and 6 speed set up. I already ordered the IDS for it so that souldnt be an issue soon.Even that isn't trouble it's more of an annoyance because the noise wont hurt anything I just don't want to listen to it.
     
  4. Zamadan

    Zamadan Active Member

    195
    26
    0
    Knock on wood, haven't had any problems with my 07 EG except my rear tire wore out at 10,000 miles. :D Put in a stage one with V&H ovals and a techulsion, pops and backfires a little to much for my liking but working great. The 07 tranny gives good mileage and has great pick me up, even when riding two up loaded. Overall I think they are awesome bikes.
     
  5. Sharky1948

    Sharky1948 Junior Member

    640
    28
    2
    No problems other than I don't get to ride it enough!
     
  6. USMCCWO5

    USMCCWO5 Junior Member

    419
    26
    0
    Over 8000 miles on my 07 FLHRC. I haven't had a single problem. I am completely happy. I also haven't had any bad experiences in the two or three shops I have visited here in SoCal.
     
  7. dhog

    dhog Active Member

    147
    28
    2
    05 EGC no problems except every time I go to the dealership I'm one step closer to being able to apply for food stamps! Wonder if I can use them fro more chrome.:p:44:
     
  8. Fourdogs

    Fourdogs Junior Member

    805
    28
    3
    Very very pleased...with my 2004 RoadKing...Never owned a Motorcycle before in my life. I waited till I was 58...and I think it was the best thing I could have done after retiring.I have 45,000 plus miles on her. Had the best of luck with mine and seen this here country and done it all on a Harley...of course I'm a retired Utility Worker...union man for 37 years and proud of it..so would buy nothing but Harley...and I don't care who knows it...BTW I've loved chroming it up!:D
     
  9. Buckwild Biker

    Buckwild Biker Member

    76
    16
    0
    Well up until this week I would have had to agree with everyone, but now that I have had my girl in for the 1000 mile service, the problems have begun. Up until that the bike was running like a top. No sooner had I got her home the check engine light started coming on--and staying on, and the battery indicator did the same thing. Evidently I now have an electrical/fuel system problem that I never had before. Not sure what the service department at the dealership did wrong, but something happened. I can't even get the battery to recharge enough to drive it back to them--about 30 miles. I also had a tach installed, so maybe something went wrong with the install. To top it off when I called the dealership today for a pick up of the bike, they informed me that it would be at least a week as all the company trailers where being used by the dealership big shots on a week long bike trek somewhere. Needless to say I am not very happy right now. I am hoping that I can have a change of heart soon, and that I can be back on the road with my 2007 Dyna Super Glide Custom... :(
     
  10. glider

    glider Veteran Member

    25,464
    108
    44
    Check your battery terminals. For some reason the Dynas have had a lot of loose ones causing this problem.