Adjustment and Troubleshooting of Clutches

Discussion in 'Transmission' started by jmunsey, Apr 23, 2012.

  1. jmunsey

    jmunsey New Member

    2
    11
    0
    Looking for some help here, I have a 2007 Police Road King (FLHPI). It just rolled up to 45K and I did the engine, tranny, and primary oil change myself. I used good oil in all and the correct oils. The first 120 miles or so all was fine. Then I started hearing a racket coming from either the tranny or clutch. A chattering sound that got fairly loud. If sitting there idling in neutral you hear the chatter. If I put it in gear with the clutch pulled in and am not moving the noise goes away. When I am rolling down the road the noise is back. There are no leaks and I pulled the derby off yesterday to take a look and all looks fine.
    I thought maybe I screwed something up when I did the service but all seems fine and it was working fine right after. Any ideas on this?

    Note: This bike is attached to a large sidecar and I also have a Champion reverse kit installed (1+ year now). If I place in reverse or first gear with clutch in, no noise. Only in neutral or rolling down the road. This clutch gets a lot of abuse and it is the stock original clutch. Could it have just worn something out? Tranny shifts up and down fine and no slippage or sticking. Just that chattering racket.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    The 6 speeds do tend to get noisy, they have a weak trap door compared to the 5 speed, you may try a heavy GEAR oil to tone it down some, when you change your clutch out try Barnett also try this
    http://www.hdtalking.com/archive/t-738.html