'88 FXRS: Starter or Electrical?

Discussion in 'FXR Models' started by fxrsrider, Sep 27, 2011.

  1. fxrsrider

    fxrsrider Member

    5
    0
    0
    She's been running great lately, started her up the other day to head back home. It turned over but I heard a humming noise...like a fan running. Put it in gear and it stalled....humming still running. Turned off ignition, pulled key out, humming still running. It hummed until the battery drained. It was definitely the starter that was humming. Do I replace the ignition and relay first? Could one of those two be the problem? The bike details are below...


    It's an '88 FXRS. It has a Softail front end and forward controls, Fatboy front wheel and tire, 160 rear wheel/tire (original swing arm), Bourget brake and clutch levers (original calipers), custom Works suspension, Mikuni carb, and RB 2into1 exhaust. I had the Evo's top end rebuilt (new pistons, powder coated inside and out, re-honed, etc.) about a year ago and added an Andrew's EV3 cam and a new OE cam cover. I also had the starter replaced with a Spyke high torque starter. No original handlebar controls, no turn signals, no speedo, key ignition, etc... .....believe it or not, I am the third owner and have the original HD dealer bill of sale, owners manual, etc.......a close friend bought the bike before me. I really enjoy the bike but haven't done any work on it myself apart from installing the RB exhaust.
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Sounds like the starter is staying engaged , I would have a look at the solenoid, the relay and the ignition switch in that order
     
  3. fxrsrider

    fxrsrider Member

    5
    0
    0
    Thank You, Jack. Will do.