87 FXR Problem

Discussion in 'FXR Models' started by roxthaworld, May 13, 2012.

  1. roxthaworld

    roxthaworld New Member

    3
    0
    0
    I have a Annoying miss in my FXR when traveling at high speed it will feel like its only running on one cylinder, I changed the spark plugs and leads and it fixed it for 500ks or so now the problem is back? Could it be dodgy leads or something further

    I checked the coil pack and the first cylinder has 2 wires and second has 1 would this make any difference?

    Any help would be grateful
     
  2. roxthaworld

    roxthaworld New Member

    3
    0
    0
    Also could someone suggest the best Leads and Spark plugs for this bike?
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    This is V fire 1 or 2? I dont remember for sure, any way they were a problem in the early days of electronic ignition, if New wires and plugs do not fix the problem I would look in the cone at the trigger and advance mechanism, check the wires coming out of the cone, they get brittle over time and will short out and burn up, l would have a close look at the wires at the coil also check for tightness , spray some water on the coil while @ idle does the engine die may be a crack in the coil I assume this is stock dual fire ignition? Pay close attention to the advance mechanism, would not be the first one to go bad Good Luck and report back
     
    1 person likes this.
  4. roxthaworld

    roxthaworld New Member

    3
    0
    0
    Pretty sure its a V2 and a stock dual fire ignition