4 ways flashing

Discussion in 'Touring Models' started by jdgreen454, Jun 26, 2010.

  1. jdgreen454

    jdgreen454 Member

    21
    11
    0
    Not sure if this has been covered before. I just picked up an 01 Electra Glide Classic and was wondering if it is normal for the four ways to flash when I turn the ignition on? Everything looks to be working normally. Does this have something to do with the alarm system? thanks
     
  2. whatyardwork

    whatyardwork Banned

    829
    0
    4
    The only reason the 4 ways would flash is due to the alarm.
     
  3. Chopper

    Chopper Senior Member

    1,632
    48
    18
    If the turn signals flash six fast four-way flashes shortly after key ON, then an error code is logged.

    Invoking TSM/TSSM Code Diagnostics
    Set RUN/OFF switch to OFF
    Turn IGN key ON-OFF-ON-OFF-ON
    Press left turn switch 2 times and release
    1-3 flashes turn signals & indicators depending on vehicle configuration
    1 flash-Worldwide TSM, no security
    2 flashes-North American/Domestic configuration TSSM
    3 flashes-European/HDI configuration TSSM
    Press right turn switch 1 time and release-1 flash turn signals & indicators
    Press right turn switch 1 time and release-2 flashes turn signals & indicators
    Press right turn switch 1 time and release-3 flashes turn signals & indicators
    Press left turn switch 1 time and release-turn signals & indicators flash to indicate trouble codes
    To clear codes, press and hold left turn switch for 4-5 seconds until confirmation is received-2 flashes turn signals & indicators
    Turn IGN key OFF
    The codes should be listed in the self help if you do a search, I think
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
  5. marty

    marty Member

    53
    18
    1
    my 01 electra-glide classic has done that twice and both times i had to buy new battery and problem was gone!!make sure cables are clean and tight first!i have alarm with two key fobes never used they are in closet when bike would actup.keep me posted
     
  6. jdgreen454

    jdgreen454 Member

    21
    11
    0
    Alright fellas 2 months later and I still have the flashing problem. I've cleaned the battery connections and tried clearing the codes numerous times and still nothing. Codes seem to clear out, everything flashes the way it should. Bike runs great so I've just been ridin it. Any other suggestions. thanks
     
  7. RibEye

    RibEye Junior Member Contributor

    973
    48
    45
    Can't help at all, until the specific error codes are revealed...

    Enjoy,
    Rich P
     
  8. Robert Walter

    Robert Walter Member

    52
    16
    0
    Wouldn't happen to be in the emergency drive mode would it ? IGN. on push both L & R switches at the same time.
     
  9. jayray

    jayray Member

    13
    0
    0
    We like to turn on all four when we get to RR tracks. Gotta time it right hitting both directionals at the same time.
     
  10. TripleJ

    TripleJ Senior Member

    1,081
    48
    8
    Can't say if this pertains to your ride as I do not have a manual for it but on my 08 Heritage I have 2 key fobs. When I used one of them the turn signals would flash a few times and then stop when I turned the ignition on but when using the other fob all worked well.

    Figured the battery might be bad in the fob so I checked the voltage (should not be less than 2.9V according to manual) and it had 2.75V. Replaced the battery (both fobs btw :D) and problem solved.