2014 street glide turn signal problem

Discussion in 'Electrical' started by Bowling Coach, Apr 6, 2014.

  1. Bowling Coach

    Bowling Coach Member

    11
    11
    0
    having a problem with turn signal turning of before i make a total turn any ideas
     
  2. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    It's a 2014 - take it back to the dealer and make him fix it.
     
  3. Bowling Coach

    Bowling Coach Member

    11
    11
    0
    I will just like too know if anybody has had this problem
     
  4. hillbilly81

    hillbilly81 Active Member

    356
    26
    0
    my experience with more than one model is that sometimes they stay on longer sometimes not
     
  5. tourbox

    tourbox Senior Member

    1,308
    68
    54
    They are a timed based circuit based on speed. The slower you are going the quicker they turn off, vice versus faster the longer they stay on. If you turn them on way before your turn it could turn off before you expect. The timer circuit doesn't start until you release the button, Press and hold the button in a little longer, then release it. See if that helps. I've never had the problem you speak of except on early '90's models.
    tourbox
     
  6. hillbilly81

    hillbilly81 Active Member

    356
    26
    0
    good explanation on that tourbox
     
  7. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,310
    73
    130
    Isn't the bank angle sensor involved too? Or is that only earlier models?
     
  8. Breeze3at

    Breeze3at Well-Known Member

    4,643
    83
    123
    Unless changed for 2014, the bank angle sensor is involved. The BAS will turn signal off as soon as a turn (lean) is made, no matter what distance or time is involved.
     
  9. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    This should work on all current models, good advice here Ray:s I tried it on every bike since 1992 and it works fine