2011 ultra classic limited with leaking rear shock

Discussion in 'Touring Models' started by yharley, Sep 5, 2010.

  1. yharley

    yharley Member

    12
    0
    0
    My new bike has holes already! Have you experienced this problem. Vehicle shock started leaking with less than 500 miles.
     
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,633
    68
    100
    This is a brand new bike that you are having trouble with (tranny and rear shock leaking)? Take it back and DEMAND that they fix EVERYTHING that is wrong with it!!!

    TQ
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Back to the dealer, warranty issue
     
  4. bonsi57

    bonsi57 Active Member

    178
    26
    0
    Both should have been caught by the dealer during the set up/prep by the dealer. They should give you a loaner bike since you will be without your brand new bike.
     
  5. larryjmiller

    larryjmiller Junior Member

    448
    26
    0
    yharley, what do you mean by leaking and "holes".
     
  6. walleye

    walleye Junior Member Contributor

    944
    28
    2

    DITTO, what are you waiting for? If this was a new car would you not already called the dealership?
     
  7. glen073

    glen073 Active Member

    176
    26
    0
    A friends 2010 FLHX had the same issue at less than 500 miles. It was the left rear shock that went out. So far in 5500 miles, I've replaced the shifter shaft, when the rear shifter would not tighten and my horn fell off the other day and was hanging by the wire. Both were fixed within minutes at my local dealer. The first under warranty. The horn part was replaced and they didn't even write it up. Said they had the extra part laying around.
     
  8. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Glen073 "--they had the extra part laying around?" Maybe when they did the PDI they left it...out?!!! :bigsmiley6:
     
  9. jvalny

    jvalny Member

    13
    0
    0
    Well here is my story. 2010 Ultra LTD. Left side shock leaking after 3000 mls
    Replaced under warranty. 3500 mls Both shocks leaking oil. Back to the dealer.
    Apparently the routing of the ail oil lines under the rear fender broke when the rear wheel rubbed up against the lines. Rerouted new lines under the seat and new shocks were ordered. Check the lines were they meet and if they are under the rear fender. When you hit a bump the rear wheel rubs up against the lines.
     
  10. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
    Hello, was there a change in the routing of those lines in 2010? Service Bulletin? Hmmm, frame change was in 2009...?