2011 flhx alarm..

Discussion in 'Touring Models' started by rydahog, Aug 3, 2014.

  1. rydahog

    rydahog Active Member

    228
    26
    0
    I searched all over, i cant store my PIN code for my alarm fob after programming it in with my turn signals...everything i have read says turn ign. to off position before it re-sets by it self.. HeLP!! thanks ...or is it off to the dealer for this? later..
     
  2. rydahog

    rydahog Active Member

    228
    26
    0
    just wanted to add this...fyi....
    i approach bike the alarm red key is flashing, but the turn signal lights do not flash as they used to in the past, and when i walk away also they DO NOT flash to Arm the bike..
    i tried all the on/off/on/on...TS functions...re-did code, but it wont Store in the odometer area. any other suggestions is appreciated, i feel this is the problem (no-storing of code) but after i put in code, i turned ign off,,,,i also put in code and hit Right tS once then ign off...but still no luck.
     
  3. dbmg

    dbmg Experienced Member

    5,800
    153
    318
  4. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    If the signals don't flash when arming, the fob battery may be bad. That could cause code to not store. Also, when doing the code, the bike must be on the jiffy stand, and don't sit on or jiggle the bike.
    You are trying to change the old and store a new code, right?
     
  5. rydahog

    rydahog Active Member

    228
    26
    0
    Well i am back,,and i apologize for taking up your time for my stoopid..:)
    after much searching and back and forth, i said to myself..."SELF" what if the new FOB battery was BAD.....soooo i open the key fob cover,,and low and behold...i installed it upside down...yikes!...so now its all good....man i hate my eyes without glasses..thanks to all for your input...time to ride...:)
     
  6. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Do not be so hard on your self. Many have learned a lesson here.......
    As the saying goes, "it's all good......."
    No harm no foul.:s
    Be sure to check the other remote!!!!
     
  7. rydahog

    rydahog Active Member

    228
    26
    0
    ok i am back...after removal and replaced TSSM, it re-set and bike started fine,,,after bike sits for a while, bike will not start, my question is, if i replace this TSSM do i need to also change the key fobs? or will it sync ok with tssm and my current key fobs? thanks, p.s. battery is fully charged and new batt in fob..
     
  8. Breeze3at

    Breeze3at Well-Known Member

    4,645
    83
    124
    The TSSM and FOBs are "married". Any change requires dealer to perform a new ceremony. With a fee of course.
    I can't remember right now but I think it's the ECM that requires the reprogramming? The TSSM doesn't have memory, just code?
     
  9. rydahog

    rydahog Active Member

    228
    26
    0
    update, so i disconnected my existing hfsm (or tssm as some call it) then i disconnected my bike Batt, reinstalled the hfsm, reinstalled my batt, (found a loose wire that was under battery terminal for my dobeck, re-prog. the pin etc...hooked up battery charger and it started fine,,,good as new, then i hooked up my trickle charger, charged fine all night to full capacity, so my question to my self is..did i inadvertently cause all this myself, by forgetting to put the key fob in my pocket the first time i came to start bike? and think it was a bad bike ecu problem? In any case the bike is fine now...:newsmile100:
    have a good day,,i am sure i will back in the future for some other things i mess with...:D
     
  10. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    It is possible that the security system was seeing that bike was being tampered do to the loose connection and was shutting down as designed....