2009 Fat Bob Exhaust Issue

Discussion in 'Dyna Models' started by bass33, Jul 26, 2010.

  1. bass33

    bass33 New Member

    2
    0
    0
    Hey guys,

    I'm brand new to this site. I just purchased an '09 Fat Bob in March and have about 2200 miles on it. A friend and I just rode down to the Outer Banks from CT last Saturday and now I find myself stranded.

    The 3 bolts that connect the exhaust to the frame are completely sheared off. I am not sure how or why this happened but I feel like this is something that should be covered under the warranty, especially since its only been 4 months. Has anybody had an issue like this with their Fat Bob or any other bike? What would you suggest doing? I need to be on my way home on Saturday and am not sure what to do. I will be on the phone tomorrow morning with the dealer so any suggestions would help.

    Thanks guys,
    Stranded in the OBX
     
  2. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    Have them check the motor mounts, if they flex a lot it can strain the exhaust system, MyStreet bob sheared the rear exhaust bracket, you should have a warranty issue here good luck:s
     
  3. bass33

    bass33 New Member

    2
    0
    0
    Thanks! Do you know what the warranty covers? Is it just parts or does it cover the labor as well? I don't have the documents down here on vaca.
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    should be fender to fender and they can pull it up by the VIN:s