2006 FXDLI Intermittent Tach/Speedo

Discussion in 'Dyna Models' started by Jetfixer, Aug 7, 2011.

  1. Jetfixer

    Jetfixer Member

    19
    0
    0
    Have had this intermittent tach/speedo problem for a while now. Checking engine diagnostic codes afterward always shows same, U1097 Loss of Speedo Serial Data EFI. I have cleaned speedsensor, checked grounds and connectors for instruments but still have this intermittent problem. One clue I noticed this time was that the internal instrument lighting blinked off when tach/speedo flopped down. I can clear codes and everything may be good for two or three rides and then irregardless of time, temp, etc. I get this problem. Anyone have any suggestions on what to do next???:(
     
  2. Jetfixer

    Jetfixer Member

    19
    0
    0
    Found my problem if anyone would like to put back in their memory bank. Intermittent problem caused by faulty Ignition/Fork Lock switch. I also believe a contributor to the intermittent switch was the key fob on the key ring flopping around. Replacing ignition switch this week, removed key fob from key ring also. For what it's worth
    jetfixer
     
  3. Hoople

    Hoople Account Removed

    7,198
    0
    34
    Wow, I would never want to jinxs your ignition switch fix but I am surprised you fixed a U1097 with the replacement of the ignition switch. I would have expected a bad ignition switch giving you different symptoms and DTC's . Very interesting & good to know. Tks!
     
  4. Jetfixer

    Jetfixer Member

    19
    0
    0
    I was also surprised. I could duplicate the intermittent tach/speedo by wiggling key. As I continued to play with the problem I could acutally get the diagnostic system to "not test" at all depending on how much I tightned the ignition switch mount ring. Tight, system wouldn't test at all, completely loose system functioned normal... in between had intermittent problems..