2002 FLHTCI Fuel Injection Issue - Won't start

Discussion in 'Engine, Fuel and Exhaust' started by hangerbum, Dec 18, 2015.

  1. hangerbum

    hangerbum New Member

    2002 FLHTCI 12k miles, was running then sat in garage for 1 year. Tried to start but fuel line in tank broke when pressurized, thus fuel just circulated in tank with nothing being delivered to injectors.

    Took off tank, removed fuel pump assembly, and cleaned tank with phosphoric acid. Replace with new fuel pump assembly and hose. Removed injectors and cleaned by forcing B-12 through injectors while activating with 9 volt battery. Attached light to injector harness, it flashes as engine turns over. Reassembled and tested fuel pressure. It initializes to 60 psi.

    The darn thing won't fire up!:cry Starts right up on a squirt of starter fluid and runs till starter fluid in consumed.

    Any help/ideas?? Thanks in advance for your advice!

    BUBBIE Well-Known Member

    Do you have the connectors to the Injectors Good? saying red light? What about the ID Plug into OD Plug wires left side of the Injector Manifold..

    Wiggle test... Try to start,,,,, Some times you can have damage pin when apart and not aligned when together...... Reconnect after Looking into the Plug...

    Not knowing the Type fuel tank Connector...??????? Hose like on a compressor air line type? Male connector into the Female tank connector?

    On the 07 (I know u r 02) Lifting UP so the line pushes INTO the female HOLDING THERE TRY to start........ ALL the way into the tank connector allows full out of fuel pressure....? worth a try if that is the way it is set-up .....

    No Start.... Try a different set of Injectors IF they are getting Pressure...
    I then would think it may be from Pushing cleaner/fuel thru the Injectors with your by-pass cleaning method... ? :small3d001: