1996 Fat Boy electrical problems

Discussion in 'Softail Models' started by kevinbag, Sep 14, 2010.

  1. kevinbag

    kevinbag New Member

    2
    0
    0
    Hi Guys I recently bought this bike and its electrical system, lights, horn, starting then not starting, etc is a big problem, working then not working. Can anybody help me out with a wiring diagram so I can check the whole system out. Thanks. Kevin
     
  2. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,276
    133
    156
    Start by taking both of the battery cables off the bike clean both ends and the arear they seat refit and see if it makes a difference even if they look clean clean them anyway
    always remove negitive firat and fit last

    Brian
     
  3. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    4,630
    68
    99
    Kevin,

    Welcome to the Forum. You will find lots of great info in the Self-Help pages, and in the heads of your fellow members.

    On your electrical problems, I suggest you start with the basics. Disconnect the battery terminals (negative first) at both ends, clean both mating surfaces with a wire brush and reconnect the cables (neg last).

    Then check the fuses to ensure that there is not a build up of corrosion by-products in the sockets.

    Check the grounds under the seat and around the bike to make sure all are secured tightly and that there are no corroded wires.

    Most of the time, these type of things are the cause of intermittent problems like you have.

    Let us know. If necessary, we will move on the the more complex.

    TQ
     
  4. kevinbag

    kevinbag New Member

    2
    0
    0
    Thanks for the advice. I will let you know how it goes.