09 street bob backfires often

Discussion in 'Dyna Models' started by Jeffburke, Jun 18, 2009.

  1. Jeffburke

    Jeffburke Member

    20
    11
    0
    My 09 street bob has always backfired somewhat upon deceleration, but has recently become louder and more noticable. The other day as I was leaving work, it backfired loud as I tried to crank it. Never done that before and Sounded like a gun fired off. Since then I have noticed it more and more. Could this be a sign of a lean condition? Bike has 6100 miles on it and basically stock, except for stage 1 AC and Rush slip-ons. Any suggestions as to what might cause this? Thanks, Jeff
     
  2. Devil Dogg

    Devil Dogg Member

    22
    11
    0
    I was told by my dealer that if you do both the pipe and intake upgrade then you will lean it out to much. I would suggest an ecm reprogram.:20:
     
  3. Jeffburke

    Jeffburke Member

    20
    11
    0
    have never purchased fueler. Had stage 1 A/C upgrade, slip-ons and dealer remap. What brand fueler you use? Can I return to dealer and have A/f richen? or would it be best to buy fueler. The hotter it is outside, the worse it gets. Been mid to upper 90s round here in Alabama. I bet if its runnin lean then its probably runnin hotter, right?
     
  4. RickyBobby

    RickyBobby Active Member

    171
    28
    1
    While doing that, you should be sure there are no intake leaks too. :)

    I get a slight pop if I decelerate hard in my V&H pipes. I have had it dyno mapped and I feel like the bike runs well enough with the pipes and the High 5 intake I have on it. The slight pop is actually not offensive to me. It is nothing like a backfire though and I attribute it to unburned fuel in the pipes. It won't do it cold.
     
    Last edited: Jun 25, 2009
  5. Jeffburke

    Jeffburke Member

    20
    11
    0
    Thanks, read some reviews on the TFI and saw nothing but good things about it. Going to order next week.
     
  6. glider

    glider Veteran Member

    25,464
    108
    44
    Don't forget to mention the forum and get free shipping.
     
  7. RickyBobby

    RickyBobby Active Member

    171
    28
    1
    I just ordered the XiED set up. No, I don't know why, but it is getting hotter and it is plug and play. I am sure that it will help a little if not a lot, since I have the stock oxy sensors. I actually ordered the DYN OiED cables, since I have an 06 Dyna with intake and exhaust mods.

    Once I get the kit, I will be anxious to give it a seat of the pants test.