07 Wide Glide Cuts out and dies

Discussion in 'Dyna Models' started by maples, Sep 9, 2013.

  1. maples

    maples New Member

    1
    0
    0
    I have a 2007 Wide Glide, lately it has started cutting out abd dies when I come to a stop sign. It starts up right away and it doesn't do it all the time. I can go on a short ride and it will do it everytime I stop and the next day, I can do the same ride and it won't do it at all. I can't figure out the issue. Has anyone else had this issue???
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Check the engine temp circuit, the ECM would need to be replaced. have you cleaned the IAC and the CPS?
     
  3. gefhd

    gefhd Member

    8
    0
    0
    Try looking in gas tank when engine off turn ignition on while looking inside and see if any fuel spraying have seen cracked pressure regulator or worn internal fuel line (check valve assy) good luck
     
  4. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    398
    Welcome to The Forum, Harley Davidson Forums have a look here and run the diagnostics first and check back in:s
     
  5. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
  6. SilverFoXD

    SilverFoXD Active Member Contributor

    382
    28
    9
    Had the same issue with my '07 Dyna when I would accelerate then back off to stop. Happened on the Blue Ridge Parkway pulling from an overlook then stopping at the next that came up suddenly. There was also an altitude difference but that should not have been an issue with fuel injection, and a lot of up-hill acceleration.

    Might not be a mechanical issue for you, just the riding circumstances at that time.