04 fxd turn signal question

Discussion in 'Electrical' started by Spears7100, Nov 5, 2007.

  1. Spears7100

    Spears7100 New Member

    4
    11
    0
    Hey all I've got a problem with my turn signal that just popped up, the left functions properly but when you hit the right the emergency flashers turn on, I tore my bike apart trying to find a problem , but it doesn't seem to be a wire break or anything along those lines, at 2:30 am i found myself holding the little box that runs the security system. Am i way off base? ( I have to go get a wiring diagram), it wasn't an intermittent problem, just all of a sudden I was getting flashers instead of a turn signal, anyway any help would be appreciated, thanks.:
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
    Have you added anything lately since this started like chrome switch housings. (pinched wire) That black box you found is the TSSM or TSM depending if you have a security system.
     
  3. Spears7100

    Spears7100 New Member

    4
    11
    0
    Yea sorry it took so long to reply, what a day to get a virus, all my lighting is aftermarket with kuryakyn led mini bullets in the rear, but everything has been working fine, with no modifications to the lighting for about a year, I do have a security system, but I have an electronic display, so i have no idea how to pull codes from it....my buddy has an 03 dyna low with the same security type setup, i wonder if i should swap modules just for troubleshooting purposes? Cajun harley is the local harley shop here and they suck, they don't even have the manuals, every time i deal with them they have to order. Anyway thanks for the help. .....I was just looking at the kuryakyn site and i see that they have a load equilizer that is compatible with harley security systems, the equilizer i have is just the standard 2 amp... maybe thats the problem?
     
    Last edited: Nov 5, 2007
  4. glider

    glider Veteran Member

    25,464
    108
    43
  5. Spears7100

    Spears7100 New Member

    4
    11
    0
    I think I got the problem fixed, after countless hours wasted running down wires I think it was just a ground problem, I had changed one of my mirrors out and it had loosened up, after tightening it up I realised the blinkers were working fine, go figure. The funny part of it is that it was the left hand mirror and turn signal that was loose and it was the right hand blinker that was acting up. Well thanks again for all your help, at least I found a cool forum in the process.
     
  6. glider

    glider Veteran Member

    25,464
    108
    43
    Glad you made some progress with the problem. Some things can be difficult to track down.