04 eletra glide starter issue

Discussion in 'Touring Models' started by rsmull, Apr 19, 2010.

  1. rsmull

    rsmull New Member

    Ok, here's my issue. When I push the start button i hear a soft click, but no starter rotation. When i then release the start button i hear a louder click. I have diagnosed that it is a starter solenoid issue. If i imediately remover the cover solenoid cover and manually push it in it will work, even after i replace the cover and use the start button. i have cleaned the solenoid contacts , but it didn't seem to help. it only happens periodically. so, do i replace the whole starter are just put a selenoid re-build kit in it?
  2. TQuentin1

    TQuentin1 Well-Known Member Staff Member Moderator

    Before doing all that, remove the battery cables, clean the mating surfaces of both ends of both cables with a wire brush and resecure (neg last). Make sure your battery is fully charged. See if that made any difference.

  3. glider

    glider Veteran Member

    It could also be the starter relay causing the problem. If the contacts are burnt, it would cause low power to the solenoid and it could be mistaken as a solenoid issue. Cheap enough to replace the relay and they are cheap just to be sure. You can also bridge the terminals on the relay to eliminate it as the source.

    Terms 30/51 to term 87 should tell the story. They should be numbered on the relay and if you bridge them with a wire in the plug, the starter should crank if the relay is the problem.

  4. tourglider

    tourglider Member

    Had the same problem on a 95 tour glide ultra. It was the ignition switch.