02 Heritage - Low/High Beam Help Please

Discussion in 'Electrical' started by 2002SilverSurfer, Nov 7, 2008.

  1. 2002SilverSurfer

    2002SilverSurfer Active Member

    130
    26
    0
    So in the past month, I've noticed that on occasion my low beam bulb quits working. I have the aftermarket Harley headlight with seperate high and low beam bulbs. I drove to work one day with teh high on since the low wasnt working. Went to Harley and ordered a new low beam bulb. Noticed the next day that the low beam bulb was working. Good deal...bulb is working and I will now have a spare. Yesterday, I notice the low beam is out again. When I click the switch for high beams, both bulbs illuminate. I swapped out the low beam bulb for the one I ordered a few weeks agao and still no joy. I checked the fuses and still no joy. I checked what wiring I could see behind the headlight and under the seat with no apparent rubs or loose connections. Any relays or anything that could possibly go bad??

    Thanks,
    2002SilverSurfer
     

    Attached Files:

  2. SledDog

    SledDog Senior Member Staff Member Moderator

    1,852
    58
    43
    Maybe your low/high switch is going bad. The contacts maybe corroded. If you have a manual, check the diagram and verify all the wiring is good. The includes the low/high switch and the grounds.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Take a look at the wires where they go into the plug on the bulb. Been some problems with them in there.
     
  4. Zamadan

    Zamadan Active Member

    195
    26
    0
    Brother had the same problem, there was corrosion on the pigtail connecter where the bulb plugs in.
     
  5. glider

    glider Veteran Member

    25,464
    108
    44
  6. 2002SilverSurfer

    2002SilverSurfer Active Member

    130
    26
    0
    I'll have to check the connections a bit more closely. I suppose I could crack open the switch on the handlebar too?? Anything I could break in there??

    Thanks,
    2002SilverSurfer
     
  7. 2002SilverSurfer

    2002SilverSurfer Active Member

    130
    26
    0
  8. glider

    glider Veteran Member

    25,464
    108
    44
    Shouldn't break anything, but going back together, position the halves the way it goes and then insert the screws while holding it in place so no wires get pinched.
    Also space the brake lever too so you don't break the switch, shouldn't really be necessary but do it anyway.

    [​IMG]
     
  9. 2002SilverSurfer

    2002SilverSurfer Active Member

    130
    26
    0
    Update: 02 Heritage - Low/High Beam Help Please

    So I've been riding around with high beam light since I posted this...checking every so often to see if the low was working. On my way home from work Friday night, coming down my rock driveway, I had just the passing lamps on since low wasnt working...took a bump over a larger rock and Viola!! the low beam comes back on. It stayed on for my whole ride into work today so something is loose somewhere.....

    Looks like I know what tomorrows project will be..... :D

    Later,
    2002SilverSurfer