Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

08 Ultra Radio Problem

Touring Models

Reply
 
Thread Tools Display Modes
Old Feb 6th, 2011, 01:36 AM     #1
Warming The Wheels
Ride: 2010 Street Glide
 
ppofootball's Avatar
 
Join Date: Oct 20th, 2009
Location: Miami,Florida
Posts: 57
My Mood: My Mood
ppofootball is an unknown quantity at this point
08 Ultra Radio Problem

I've had my Ultra now for a couple weeks and have gone on two weekend trips about 200+ miles round trip and today as I started out for another to the Everglades Seafood festival my radio started cutting out like it had bad reception. I put the CD on same thing some times staying off for a minute or two at a time. Ipod, same thing. Thought it could be battery cause bike is two- three years old but only 5700 miles and the bike starts one touch and lights and everything else seems to be fine. I keep it on a tender and got the gren light.
I got home and turned to the experts here and searched Radio Problems. A couple came up over a year old but the exact same problems. Some of the cures were to have the radio upgraded. What I didnt see is if anyone had their system upgraded and did that solve the problem.
I checked the radio for my software version and it is 8.19. I went to the Harley site and that looks like the latest version.
Is anyone out there who had these problems and what was the fix?
__________________
2010 Street Glide, Black Denim,ABS,Security,SERT, Sinister up your exhaust,Yaffe 13"Monkey Bagger Bars, Battistinis collection floorboards,a/c, horn,shifter ,brake etc.. PM Renegade 21" front and 18" rear wheels w/ 200 Tire
ppofootball is offline   Reply With Quote
Old Feb 6th, 2011, 02:35 AM     #2
Warming The Wheels
Ride: 2010 ultra classic electra glide
 
tubguy's Avatar
 
Join Date: Oct 13th, 2010
Location: Kamloops,BC Canada
Posts: 139
My Mood: My Mood
tubguy is an unknown quantity at this point
Re: 08 Ultra Radio Problem

Not sure if this will help! On my 2010 eg i had somehow had my cb turned on and it interfeared with tha reception and the sound. I can say that I`mnot too impressed with the quality , my aux input has decided not to work when I plug in my Sat Radio
tubguy is offline   Reply With Quote
Old Feb 6th, 2011, 05:19 AM     #3
Community Star
Ride: 2007 Ultra Classic
 
Join Date: Sep 11th, 2009
Location: Dubuque, Iowa
Posts: 543
gusotto is an unknown quantity at this point
Re: 08 Ultra Radio Problem

A few years ago, I had the V 8.19 software upgrade on my '07 Ultra (from V8.09) and it fixed my cutting out problem. Acted like a loose antenna but when it did the same thing while playing a CD, I knew it wasn't an antenna problem.

Out of curiosity, I'll check some of the new bikes on the showroom floor.
V8.25 is the highest version I've found (so far.)

Wish there was a way to find out what each version was for. Fixes, improvements, etc., etc.
gusotto is online now   Reply With Quote
Old Feb 6th, 2011, 10:04 AM     #4
Community Star
Ride: Electra Glide 2009
 
Join Date: Dec 13th, 2008
Location: Jacksonville, FL
Posts: 458
My Mood: My Mood
Slapp is an unknown quantity at this point
Re: 08 Ultra Radio Problem

You may have to open the clam shell and ensure there are no loose conections to the radio, ie; power supply, antenna, speaker connections, hand control connections and so on. If you have the extended warranty you could always take it to the dealer.
Good luck with it.
__________________
Only our individual faith in freedom can keep us free.
Slapp is offline   Reply With Quote
Old Feb 6th, 2011, 11:23 AM     #5
Warming The Wheels
Ride: 2010 Street Glide
 
ppofootball's Avatar
 
Join Date: Oct 20th, 2009
Location: Miami,Florida
Posts: 57
My Mood: My Mood
ppofootball is an unknown quantity at this point
Re: 08 Ultra Radio Problem

Tubguy, my CB was on and activated for some reason I guess I turned it on when I was messing with the settings. Just deactivated it and will ride later. Thanks for the tip I think it may work.
__________________
2010 Street Glide, Black Denim,ABS,Security,SERT, Sinister up your exhaust,Yaffe 13"Monkey Bagger Bars, Battistinis collection floorboards,a/c, horn,shifter ,brake etc.. PM Renegade 21" front and 18" rear wheels w/ 200 Tire
ppofootball is offline   Reply With Quote
Old Feb 6th, 2011, 11:55 AM     #6
New Family
Ride: 2011 FLHTK
 
Join Date: Oct 8th, 2008
Location: Allentown, PA
Posts: 7
My Mood: My Mood
Vin190 is an unknown quantity at this point
Re: 08 Ultra Radio Problem

I also had the same problem and yes I had the CB on. Turned it off, problem solved.
Vin190 is offline   Reply With Quote
Old Feb 6th, 2011, 12:16 PM     #7
Retired Moderators
Ride: 2004 Sportster XL1200R
 
NEWHD74FAN's Avatar
 
Join Date: Aug 24th, 2008
Location: Camarillo, CA
Posts: 8,276
My Mood: My Mood
NEWHD74FAN is an unknown quantity at this point
Re: 08 Ultra Radio Problem

I can see the CB radio causing things to cut out because the squelch threshold and PTT (Push To Talk) simplex (1 way communication transmit/receive) causing you grief if you have other media plugged in also. Good catch Tubguy...when troubleshooting sometimes it is easier to "isolate and conquer" by simplifying conditions and retest.
__________________
* Please click "Self Help Tips" tab for service tips, diagnostic codes & such * ;o) * Please click "Search" tab and keywords to find related threads *
NEWHD74FAN is offline   Reply With Quote
Old Feb 6th, 2011, 05:07 PM     #8
Start The Engine
Ride: 06 ULTRA
 
Join Date: Jun 19th, 2009
Location: FARMINGTON, OHIO
Posts: 17
My Mood: My Mood
OUTLAW-13 is an unknown quantity at this point
Re: 08 Ultra Radio Problem

I've got caught in a hard rain before and had this happen also. let it dry for a couple of days and then it was fine.
OUTLAW-13 is offline   Reply With Quote
Old Feb 12th, 2011, 03:47 PM     #9
Warming The Wheels
Ride: 2010 ultra classic electra glide
 
tubguy's Avatar
 
Join Date: Oct 13th, 2010
Location: Kamloops,BC Canada
Posts: 139
My Mood: My Mood
tubguy is an unknown quantity at this point
Re: 08 Ultra Radio Problem

Quote: Originally Posted by NEWHD74FAN View Post
I can see the CB radio causing things to cut out because the squelch threshold and PTT (Push To Talk) simplex (1 way communication transmit/receive) causing you grief if you have other media plugged in also. Good catch Tubguy...when troubleshooting sometimes it is easier to "isolate and conquer" by simplifying conditions and retest.
NewHD, Thanks for the pat on the back. It's the weird things that are the simple things sometimes.
Tubguy
tubguy is offline   Reply With Quote
Old Feb 12th, 2011, 04:35 PM     #10
New Family
Ride: 2009 Ultra Classic
 
Join Date: Jun 28th, 2009
Location: Martha's Vineyard
Posts: 5
Llew is an unknown quantity at this point
Re: 08 Ultra Radio Problem

The latest version of the radio's software is ST10 v 8.25.0. You can download it from the HD site under Advanced Audio System.
Llew is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo & Radio Problem TwoTallWyo Electrical 5 Jan 19th, 2011 09:15 AM
radio problem on 08 streetglide poloharley Touring Models 4 Dec 16th, 2010 08:41 PM
99 Ultra Classic CB Radio Problem zonie8541 Communications And Radio 0 Jun 30th, 2010 01:40 PM
Harley radio Problem Jim Baxley Touring Models 17 Aug 17th, 2008 10:36 AM
1998 ultra radio problem jackcu Electrical 5 Jan 4th, 2007 10:23 AM