Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

Cruise control problems.

Touring Models

Reply
 
Thread Tools Display Modes
Old May 26th, 2010, 10:50 PM     #1
New Family
Ride: 2012 Street Glide
 
Join Date: May 26th, 2010
Location: South Fork, PA
Posts: 9
My Mood: My Mood
deputychief85 is an unknown quantity at this point
Cruise control problems.

The electronic cruise control on my 2007 ultra classic won't maintain speed when the set button is pushed. The amber indicator on the tach face turns from amber to green and stays green, but the speed isn't maintained. Anyone have any suggestions or solutions. Thanks.
deputychief85 is offline   Reply With Quote
Old May 26th, 2010, 11:23 PM     #2
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: Cruise control problems.

Possible cable adjustment is needed.

Cruise Control Initialization (pre 08) - Harley Davidson Community (Cruise Control Initialization (pre 08))
glider is offline   Reply With Quote
Old May 27th, 2010, 05:25 PM     #3
New Family
Ride: 2012 Street Glide
 
Join Date: May 26th, 2010
Location: South Fork, PA
Posts: 9
My Mood: My Mood
deputychief85 is an unknown quantity at this point
Re: Cruise control problems.

Thanks glider. My bike still uses cables for the throttle, and I understand there is a stepper cable. Any advise on checking that too. Thanks in advance for any assistance.
deputychief85 is offline   Reply With Quote
Old May 27th, 2010, 06:44 PM     #4
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: Cruise control problems.

Yes it has cables but what is it you are looking to do? Is it adjust the switch in the cable? This is the procedure for that too.
glider is offline   Reply With Quote
Old May 27th, 2010, 09:34 PM     #5
New Family
Ride: 1999 ultraclassic
 
Join Date: May 27th, 2010
Posts: 1
julius is an unknown quantity at this point
Re: Cruise control problems.

I have the same problem on my 99 ultra...scanner do not give us the error code....
julius is offline   Reply With Quote
Old May 28th, 2010, 02:17 PM     #6
Play The Throttle
Ride: 2008 Streetglide
 
Join Date: Oct 8th, 2008
Location: Alberta, Canada
Posts: 337
My Mood: My Mood
CalgaryBikeBum is an unknown quantity at this point
Re: Cruise control problems.

I'm not trying to speak for Glider here but. I think what he's telling you to to do is the cable lash initialization? That is explained in the shop manual? Once I had put my new SE 44mm carb on the cruise took along time to lock on and then was not at right speed? I did the cable initilization as stated in manual and it works perfect now. Hope that helps. Sorry for jumping in Glider.
CalgaryBikeBum is offline   Reply With Quote
Old May 28th, 2010, 02:34 PM     #7
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: Cruise control problems.

No problem CBB, that's what I was suggesting too.
glider is offline   Reply With Quote
Old May 28th, 2010, 03:44 PM     #8
New Family
Ride: 2012 Street Glide
 
Join Date: May 26th, 2010
Location: South Fork, PA
Posts: 9
My Mood: My Mood
deputychief85 is an unknown quantity at this point
Re: Cruise control problems.

Performed the cruise control initialization several times and all seems well ( motor revs and such ) Had the bike out a little while ago and the cruise worked twice in a row and then the same problem. Also noticed the "resume" switch turns the indicator from green to red immediately. Also, sometimes the "set" control takes a few seconds longer than usual to change indicator to green. Don't recall that happening before. Possible loose connection somewhere?? Is the module a plug-in and is it located in the fairing?
deputychief85 is offline   Reply With Quote
Old May 28th, 2010, 05:54 PM     #9
Play The Throttle
Ride: 2008 Streetglide
 
Join Date: Oct 8th, 2008
Location: Alberta, Canada
Posts: 337
My Mood: My Mood
CalgaryBikeBum is an unknown quantity at this point
Re: Cruise control problems.

Quote: Originally Posted by deputychief85 View Post
Performed the cruise control initialization several times and all seems well ( motor revs and such ) Had the bike out a little while ago and the cruise worked twice in a row and then the same problem. Also noticed the "resume" switch turns the indicator from green to red immediately. Also, sometimes the "set" control takes a few seconds longer than usual to change indicator to green. Don't recall that happening before. Possible loose connection somewhere?? Is the module a plug-in and is it located in the fairing?
The module should be located on the left side under the side cover? Attached to outside of battery box. It has a servo cable that then runs under the frame below tank and turns to the throttle body. THere the cable has a plastic piece that grabs a knob (at least on carb ) and that is how it pulls the throttle. Check that the cable plugged into cruise unit is firmly seated. There is just the one connector I believe?
CalgaryBikeBum is offline   Reply With Quote
Old May 28th, 2010, 06:18 PM     #10
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: Cruise control problems.

You may have too much slack in the throttle cable. If you adjust that and perform the initialization again, it may help you.
glider is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control recharge Dyna Models 17 Apr 14th, 2009 10:44 PM
08 ultra cruise control problems mrbil Electrical 9 Feb 2nd, 2009 09:51 PM
Cruise Control andrewb VRSC Models 0 Oct 19th, 2008 09:49 PM
Cruise Control Problems RICKY.DUNN Touring Models 2 Aug 7th, 2008 08:32 AM
cruise control nascar7613 Electrical 8 May 10th, 2008 12:19 AM