Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

1985 ElectraGlide speedometer cable issues

Touring Models

Reply
 
Thread Tools Display Modes
Old Apr 24th, 2010, 08:10 PM     #1
New Family
Ride: 1985 ElectraGlide Classic
 
Join Date: Apr 24th, 2010
Posts: 2
Ignio Montoya is an unknown quantity at this point
1985 ElectraGlide speedometer cable issues

I bought a 1985 ElectraGlide Classic last fyear from the original owner; it has always been garage kept and is in pristine condition.
The only issue with this bike is it eats speedometer cables.
I know the original owner replaced the speedo cable numerous (3+) times while he had it (He did not ride it much; I know of one 4 year stretch when it never left his garage) .
I have had 2 speedo cables put on it in 18 months, and both of them have broken, the second one less than 3 miles after it was installed.
I am not doing the work myself, I am paying the local shop to do it, and they have done excellent work with everything else, so I do not think it is (or at least not solely) mechanic error.
This is my first Harley, and I would really like to have everything working correctly. Can anyone give me some ideas about how to resolve this?
Ignio Montoya is offline   Reply With Quote
Old Apr 24th, 2010, 08:16 PM     #2
Community Star
Ride: 08 FLHX S&S 106" w583 cams
 
hogrotten's Avatar
 
Join Date: Jul 31st, 2008
Location: Arizona City, Arizona
Posts: 624
My Mood: My Mood
hogrotten is an unknown quantity at this point
Re: 1985 ElectraGlide speedometer cable issues

Ignio, a little more info would help. Where is the cable breaking at? The middle or on the ends?
hogrotten is offline   Reply With Quote
Old Apr 24th, 2010, 08:38 PM     #3
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: 1985 ElectraGlide speedometer cable issues

From the sounds of it, the speedo head may be dragging/binding and causing an excessive load on the cable itself causing the problem.

Try turning the speedometer head drive inside where the cable hooks into and see if it turns freely .
glider is offline   Reply With Quote
Old Apr 24th, 2010, 10:59 PM     #4
New Family
Ride: 1985 ElectraGlide Classic
 
Join Date: Apr 24th, 2010
Posts: 2
Ignio Montoya is an unknown quantity at this point
Re: 1985 ElectraGlide speedometer cable issues

Quote: Originally Posted by hogrotten View Post
Ignio, a little more info would help. Where is the cable breaking at? The middle or on the ends?
Sorry; I should have posted that initially. The 2 times the cable has broken since I have had the bike have both been at the end where it connects to the wheel, just behind the metal guard at the end of the cable.

Thanks.
Ignio Montoya is offline   Reply With Quote
Old Apr 24th, 2010, 11:06 PM     #5
Community Star
Ride: 08 FLHX S&S 106" w583 cams
 
hogrotten's Avatar
 
Join Date: Jul 31st, 2008
Location: Arizona City, Arizona
Posts: 624
My Mood: My Mood
hogrotten is an unknown quantity at this point
Re: 1985 ElectraGlide speedometer cable issues

I would first make the check that glider posted, then also make sure that the cable doesn't have too much of a bend in it at the point where it's attatched to the drive unit. Good luck,keep us posted as the best tool is experience.
hogrotten is offline   Reply With Quote
Old Apr 25th, 2010, 07:43 AM     #6
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: 1985 ElectraGlide speedometer cable issues

Another thought is was the housing changed when it was replaced too or just the inner cable? You may want to change the complete cable inner and outer. You could have a problem in the casing causing the inner cable to break.
glider is offline   Reply With Quote
Old Apr 25th, 2010, 09:30 AM     #7
Community Star
Ride: 2004 Road King
 
Jonas's Avatar
 
Join Date: Jan 6th, 2010
Location: Monroe, NC
Posts: 409
Jonas is an unknown quantity at this point
Re: 1985 ElectraGlide speedometer cable issues

I would replace the speedo drive at the front wheel. They are cheap(30 bucks) and it is a easy replacement. Eliminates that as a possibility.

When I replaced my speedo cable. I pull the center piece out first and cover it with axle grease. Then wipe the grease off, not scrub it off, just wipe it off. Alot of these cables for older bikes have been sitting around for a while.

Good Luck
__________________
2004 RoadKing Police, 1981 FLH, 1999 JR50
USMC 82-88
Jonas is offline   Reply With Quote
Old Apr 25th, 2010, 09:53 AM     #8
Community Star
Ride: 2004 flhtcu
 
Join Date: Dec 27th, 2008
Location: south western Maine
Posts: 734
My Mood: My Mood
maine-e-axe is an unknown quantity at this point
Re: 1985 ElectraGlide speedometer cable issues

Too sharp of a bend near the drive end, try a little longer cable so the bend at the bottom isn't as sharp and route the cable as straight as you can. If the inner cable isn't long enough, it may not be breaking, it may be pulling out of the drive unit.
__________________
"WE" the PEOPLE, "NOT" I the GOVERNMENT
maine-e-axe is offline   Reply With Quote
Old Apr 25th, 2010, 09:55 AM     #9
Community Star
Ride: 2004 Road King
 
Jonas's Avatar
 
Join Date: Jan 6th, 2010
Location: Monroe, NC
Posts: 409
Jonas is an unknown quantity at this point
Re: 1985 ElectraGlide speedometer cable issues

Here is a link to the drive. I think this is the one you would use 67073-81

FRONT WHEEL SPEEDOMETER DRIVE UNITS (Other)
__________________
2004 RoadKing Police, 1981 FLH, 1999 JR50
USMC 82-88
Jonas is offline   Reply With Quote
Old Apr 25th, 2010, 09:58 AM     #10
Contributor
Ride: 2007 Electra Glide Classic
 
Breeze3at's Avatar
 
Join Date: Aug 18th, 2009
Location: Warner Robins, GA
Posts: 4,149
My Mood: My Mood
Breeze3at has a spectacular aura aboutBreeze3at has a spectacular aura about
Re: 1985 ElectraGlide speedometer cable issues

I had a bit of a problem with my '92 breaking cables for a while. I had too much bend in the cable. It wasn't really noticeable, but changing it fixed the problem. Like Glider said, inspect the outer cable, it could have a spot that got kinked or bent and is rubbing on the inner. I also bought universal inner speedo cable at the auto parts store, cut to fit and cheap (if your outer cable is good)
__________________
Pete / Breeze .380
_________________________________________
I don't ride fast, but I will ride far.
Breeze3at is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
1985 Sportster Old Timer Sportster Models 5 Feb 15th, 2011 11:49 PM
New clutch cable issues Doug S Transmission 4 Apr 21st, 2010 07:42 AM
electraglide............help help dhorne Touring Models 8 Oct 24th, 2008 10:14 PM
Speedometer issues BLnews78 Sportster Models 2 Aug 15th, 2008 07:08 PM
Speedometer issues when wet gskidd Dyna Models 3 Jul 16th, 2008 06:25 PM