Harley Davidson Forums

Loading


Hello

Guest

Welcome to the harley davidson forum. Join our discussion today for FREE!

CREATE ACCOUNT

Membership Benefits

Get your questions answered by harley davidson community gurus and industry experts. Exchange your experience with another members. Access full features forum. Get a members discounts for your harley parts & accessories.

'03 Ultra Classic cruise control problem.

Touring Models

Reply
 
Thread Tools Display Modes
Old Apr 10th, 2009, 10:24 AM     #1
New Family
Ride: 2003 Ultra Classic
 
Join Date: May 31st, 2008
Posts: 4
Harley Phil is an unknown quantity at this point
'03 Ultra Classic cruise control problem.

Hello,

I have an '03 Ultra Classic, and just recently, the criuse control will, at times, not engage, and when it does finally engage, it disengages on its own, in a short time...anyone have any experience with this problem, or have any suggestions what to look for?

Thanks,

Phil
Harley Phil is offline   Reply With Quote
Old Apr 10th, 2009, 10:36 AM     #2
Wise Member
Ride: 0
 
Join Date: Jun 21st, 2007
Posts: 26,212
My Mood: My Mood
glider is on a distinguished road
Re: '03 Ultra Classic cruise control problem.

More than likely a cable lash adjustment is needed.

Cruise Control Initialization (pre 08) - Harley Davidson Community (Cruise Control Initialization (pre 08))
glider is offline   Reply With Quote
Old Apr 10th, 2009, 01:04 PM     #3
Start The Engine
Ride: 2005 Road King Classic
 
Chief4774's Avatar
 
Join Date: Feb 1st, 2009
Location: Juneau, Alaska
Posts: 21
Chief4774 is an unknown quantity at this point
Smile Re: '03 Ultra Classic cruise control problem.

I had the same symptoms and shot some electrical cleaner into the cruise control followed by a shot of WD-40. Good luck.
Chief4774 is offline   Reply With Quote
Old Apr 10th, 2009, 01:10 PM     #4
Super Moderator
Ride: 2007FLHTC
 
STEVE07's Avatar
 
Join Date: Oct 4th, 2008
Location: Kitchener Ontario Canada
Posts: 3,936
My Mood: My Mood
STEVE07 is on a distinguished road
Re: '03 Ultra Classic cruise control problem.

A friend had a similar problem on his 05 .When we pulled the AC to look behind we found rust on the cable to the module.We pulled the cable from the TB and back to the other side where we could pull it straight and spray release-all down it and worked it a few times,then put it back together,works great now.I think the additional strain was causing the module to heat up and shut down
STEVE07 is offline   Reply With Quote
Old Apr 12th, 2009, 06:40 AM     #5
Start The Engine
Ride: FLHTCUIŽ04
 
FORDENSE's Avatar
 
Join Date: Apr 11th, 2009
Posts: 10
FORDENSE is an unknown quantity at this point
Re: '03 Ultra Classic cruise control problem.

thanks for the info
FORDENSE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise Control Problem johnsondw Touring Models 5 Sep 21st, 2009 11:47 AM
93 Ultra cruise control module needed FFreer Touring Models 1 Sep 6th, 2009 09:22 AM
cruise problem 07 ultra 07electraglideuc Touring Models 12 Jun 7th, 2009 10:02 AM
08 ultra cruise control problems mrbil Electrical 9 Feb 2nd, 2009 08:51 PM
cruise control problem nascar7613 Electrical 5 Jul 25th, 2008 11:38 AM