why have my brake lights and turn signals stopped working on my 2011 Sportster but my head light sti

Discussion in 'Sportster Models' started by metalika, Jun 15, 2014.

  1. metalika

    metalika New Member

    2
    0
    0
    Hi
    Does anyone out there know why my brake lights rear running lights and turn signals have stopped working on my 2011 Sportster 48 but my head light still works?
    This has happened all of a sudden since I last rode her last week I have checked the fuses and they are ok any idea where do I go next?

    Cheers
     
  2. Dr. Dolittle

    Dr. Dolittle Experienced Member Staff Member Moderator Contributor

    6,399
    108
    24
    Not too familiar with Sportsters anymore but you have front AND rear turn signals, right? Is it just the rears that are not working? Have you carefully traced the wires to the components that aren't working to look for pinches and/or broken wires? Have you done anything at all to the bike since you rode it last and everything was working? Maintenance, mods, wash?
     
  3. metalika

    metalika New Member

    2
    0
    0
    Hi No I haven't done a thing since my last ride. With 48`s the front turn signals have just a bulb but the rear are LEDs that incorporates the turn brake and running light in the same unit. I haven't had a chance to check the wiring yet i thought I would see if anyone else has had the same problem.
    Cheers
     
  4. gusotto

    gusotto Junior Member

    597
    38
    11
    Sometimes the wiring pops out of the loom under the rear fender. Then the wiring gets chafed/shredded.
    No rear lights.
    The headlight and the other lights are on separate fuses.
    That's why HL still works.
     
  5. 4strokes

    4strokes New Member

    2
    11
    0
    Exactly ... I just bought a very low mileage 09 1200C that I found chafed/shredded wires between the fender & tail light on.
    Might not be your problem but a good place to start looking.