Whoopsi-broken mount bolt on muffler

Discussion in 'Engine, Fuel and Exhaust' started by bcortani, Apr 25, 2013.

  1. bcortani

    bcortani Active Member

    Just reinstalled the rear tire on my 08 Softail Classic after removing for a new rear tire. I followed the advice I read here and put the axel in so the next time I remove it it will pull out from the left side. All went well until I mounted my muffler...one of the top muffler anchor bolts (two that screw into the bar and holds the muffler in place from the bottom against the bar) popped its head as I was mounting it back into the hole. :cry I must of put just enough torque to break it but it didn't seem like I did...the muffler is on and the other bolt is in place and all seems nice and tight...but it is going to bother me knowing it is like that. Will have to eventually fidgit it out and replace...any advice>??:52:

    BUBBIE Well-Known Member


    Could it have been That EXTRA DoNut?

    Too much strength and SNAP..

    I thought the nut is a loose fit on the muffler bracket that is welded to it?

    Gosh, I'll have to look at my King? Should be the same...

    Are you stock on the mufflers?


    Another Washingtonian that Moved to South East Az. just to Ride every day...:lero
  3. doctor727

    doctor727 Active Member

    More than likely, the bolt head was cracked and you just twisted it the right amount. Unles the muffler is loose and rattles around, I would leave it as is until you can remove the system and do it . Time to ride for a while. Just keep in mind that you need to check the rest on the mount bolts regularly.