While running, spedometer stops and bike wants to stall.

Discussion in 'Touring Models' started by Cottle1, Apr 18, 2014.

  1. Cottle1

    Cottle1 New Member

    1
    0
    0
    I just bought a 2004 Road King Classic and the bike is in good shape overall. It starts fine, however, after running about 30 minutes, the speedometer stops, and unless I stay on the throttle, it wants to stall.

    I found a blown fuse the first time this happened and replaced it.
    Then it happened again and I replaced another.
    This last time, no fuse blew, but after the bike sat for the 5 minutes it took for me to check the fuses, it started up and was fine.

    Anyone have any thoughts?
     
  2. stray dog

    stray dog Junior Member

    443
    26
    0
    Which fuse are you replacing?

    Was the bike stored for a period of time before you bought it?

    Some more info would be helpful.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  4. tourbox

    tourbox Senior Member

    1,311
    68
    54
    I would check it for codes as well. I assume it is fuel injected.
    tourbox
     
  5. r_k_dragon

    r_k_dragon Active Member

    270
    0
    4
    Might have the battery load tested and check the connections if tests good. $0.02.
     
  6. el loco rico

    el loco rico New Member

    1
    0
    0
    Check your speed sensor on trannies , I bet your turn signals don't cancel ether . It could be crude on sensor or it may be messed up.
     
  7. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    How many miles on the bike?