weird light issue

Discussion in 'Electrical' started by redneckcarrow, Oct 14, 2014.

  1. redneckcarrow

    redneckcarrow Member

    6
    0
    0
    Hi everyone having a problem with my 2008 Harley sportster 1200 with the hfsm security system.
    went for a ride couple weeks ago the road I ended up on was a little rough. during the ride the right blinker came on not blinking along with the indicator on speedo for blinker and the key light on speedo.
    got these codes of bike out of s section B1124 and B1126 with pn 68924-07, I think is the security module.
    any help anyone can give me would be greatly appreciated.
    Thanks everyone and ride safe
     
  2. tourbox

    tourbox Senior Member

    1,311
    68
    54
    That is the P/N for the security module. I would try disconnecting the module and look for corrosion or loose connection. Put a little dielectric grease and plug back in. Clear your codes then ride it to see if it cleared your problem. Make sure the codes didn't come back.
    tourbox
     
  3. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    And also check the battery connections.
     
  4. redneckcarrow

    redneckcarrow Member

    6
    0
    0
    K thanks guys will try that.
    now if I am correct that module is under the battery right and am I going to have to reprogram any thing
     
  5. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
  6. redneckcarrow

    redneckcarrow Member

    6
    0
    0
    ok guys did what tourbox and dbmg suggested and didn't seem to help but, now have noticed more symptoms. It will start and run but when you shut it off seems like the alarm goes off with the key still in bike. only way to get it to reset is to move the fobs away from bike. then the alarm seems to reset.
    so thinking module might be shot but want you guys input
     
  7. redneckcarrow

    redneckcarrow Member

    6
    0
    0
    ok guys doing the happy dance got bike figured out and fixed this evening found a local guy that let me pick his brain gave me an idea and found some chafed wires on underside of rear fender were tire had rubbed on them. so repaired them and everything is good so happy

    ride safe guys
     
  8. dbmg

    dbmg Experienced Member

    5,800
    153
    318
    Good on you that it was a simple fix.......:s
     
  9. atm33

    atm33 Active Member

    263
    26
    0
    Wow. Glad you found that before installing a new security module! Sometimes the simplest of things..
     
  10. redneckcarrow

    redneckcarrow Member

    6
    0
    0
    the guy that helped me out has a bike shop have been back and thanked him.
    This next part not sure can do on here so moderators if not allowed just delete
    want give shout out to the guy that helped me he has a shop in Bangor called THE BIKER its in balmark industrial park wont post what he gets an hour but hole lot better then the dealer wanted. :small3d026:

    ride safe guys