Warranty and temperature questions

Discussion in 'Touring Models' started by det45, May 23, 2012.

  1. det45

    det45 Member

    As you all know I recently installed new pipes on my 2012 RKC. Everything is working great. Runs good, sounds good, and seems to be running a lot cooler. The bike has only 760 miles on it. My questions are as follows: Did I blow my warranty with the new pipes (Vance & Hines Large Radius 2 into 2 with o2 sensors and Fuelpak). Lastly I was riding my RKC in south Texas where the outside air temp was at 91 degrees. While riding my bike in stop and go traffic it ran at around 148 degrees engine temp, 138 degrees on the highway. With the stock exhaust it ran well over 230 degrees. Is this temp drop with the new pipes and fuelpak normal? Once again my bike is running great with the new pipes and fuelpak. :D
  2. Jack Klarich

    Jack Klarich Expert Member

    Wow, that is a huge drop. If the exhaust was proven to cause engine damage or the tuner the warranty would be an issue highly unlikely IMO
  3. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    You may want to check the guage, at 148 the oil is not up to recommended operating temp of 160. I coulld see a 20 to 30 degree drop but not what your experiencing. As for the warrenty you will have to ask your dealer. Some dealers have no problem with the type of upgrades you have some will. The MOCO leaves that up to each dealer as I understand it.
  4. 173ABN

    173ABN Active Member

    I agree with Don I think I would check the guage I wouldnt think any pipe tuner upgrades would lower the temp that much.
  5. Iceman24

    Iceman24 Well-Known Member

    Unless HD can prove your mods caused any damage to motor - you're good. As far as the temp drop...if it's accurate you'll have lots of customers ready to buy your patent, but I think there's an issue w/your gauge.
  6. det45

    det45 Member

    What I don't understand is the bike was running at 230 + degrees with the stock pipes and after installing the new pipes and fuelpak it runs at around 138 to 148 degrees. I don't think it's a temp gage problem but could it be that my bike was set very lean from the factory with the stock pipes and stock FI setting. The Vance & Hines Fuelpak must have increased fuel delivery thus lowering the running temp. The bike really runs well and it seems to be a lot cooler on my legs in traffic. Note: The bike has less than 1000 miles on it. :D
  7. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    No matter how your bike was set up from the factory you won't get that much of a drop in temp. Changing pipes and fuelpak will help some but not that much. Take the advice from others and recheck your guage.
  8. turnerbend

    turnerbend Active Member

    I think a good question would be "How much did you fuel mileage change" Did it improve or did it escalate? With close to a 100 degrees temp drop, you would have to had a big fuel increase to cause that cooling effect.
  9. Hoople

    Hoople Account Removed

    I agree with the others. Those sound like Celsius numbers to me. Stop & Go traffic in Texas running 148F is impossible.
    Even your original 230F during stop and go traffic in Texas is hard to believe.

    To me oil temp is not "engine temp". Cylinder head temp is what I consider engine temp to be. It's nothing to see cylinder head temps hit 300F with these late model 96 engines while sitting at a long traffic light with a fully heat soaked engine.
  10. det45

    det45 Member

    Ok, we have a long weekend so I plan on riding a lot and then I can update you all on the mileage I'm getting with these new pipes/fuelpak. I will also let you all know how the performance is working out. So far my bike is running great. As far as the temp drop is concerned I may be reading the small digital read out wrong. When I get off of work I will get a closer look at the temp gage and make sure I'm reading it right. If I'm not reading it right feel free to laugh at me because I'll deserve it......lol