vibration

Discussion in 'Other Service and Maintenance' started by galxl68, Apr 2, 2015.

  1. galxl68

    galxl68 Member

    15
    11
    0
    I have a 2012 Electra Glide police. first chance to ride since I bought it in Dec. It vibrates alot more than my 2006 Softail I had at idle. I can also feel it when I let off the throttle and glide in gear. Can the motor mount be bad with 16000 miles?
     
  2. STEVE07

    STEVE07 Well-Known Member Staff Member Super Moderators

    4,075
    68
    62
    I believe that your softail had a B motor which has less vibration at idle and rolloff and also less power.
     
  3. Breeze3at

    Breeze3at Well-Known Member

    4,811
    83
    177
    Your bikes drivetrain is all rubber mounted. The engine moves around a lot at idle, but smoothes out underway. Your softail engine was solid mounted with counter balancers inside the cases.
     
  4. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    4,257
    103
    392
    A 2012 with 16000 miles the mounts should be ok but keep in mind especially the front mount gets a lot of abuse and will deteriorate faster due to oil spills during oil changes. I agree with the above posts but it won't hurt to check the front mount periodically to make sure it's up to snuff.
     
  5. Jack Klarich

    Jack Klarich Guest

    [​IMG]
    #8 are your lower mounts, check the top stabilizer also
     
  6. galxl68

    galxl68 Member

    15
    11
    0
    Thanks for the help.
     
  7. dolt

    dolt Senior Member

    2,020
    103
    271
    Not likely that the front motor mount is bad but the later mounts are very stiff. Replace it with the Glide Pro front mount; it will make you smile.:D
     
  8. kdaddy

    kdaddy Active Member

    185
    38
    9
    +1 on the Glide Pro front mount. I started thread after changing mine out. Took about half an hour and cruising at 75 mine rides like a car.