Very angry customer

Discussion in 'Touring Models' started by Redfish-Joe, Oct 7, 2010.

  1. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    This is what the service dept. at Mike Brunos HD in Slidell La. did to my bike when they replaced the clutch cable. Funny, they say they have no record of replacing the cable. I contacted extended warranty and they gave me repair order number for the work "they never did". I also have a copy of the check I used to pay for the work.

    The wires are burned from the outside. Note the arrow. It points to what looks like to me where the pipe blew hot gasses out, which ruined the wires.

    Y'all come on down after lunch on Monday if you want to see a fat boy jump time!
     

    Attached Files:

  2. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    JUMP joe JUMP!!!!!!!!!!!!
    signed....BUBBIE
     
  3. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    I had the brake switch replaced and the cable replaced at the same time. But I have been having an on going starter problem, grinding etc.
    One of the techs I talked to about the starter before said ..too much fuel causing starter problems. Then he looked at the wires and said too lean. I told him to make up his mind ....too rich or too lean. He said the pipes got hot and caused the problem. I said show me the blue...where did they get that hot.

    The service manager then said the trailer caused the wires to burn. I told him when wires burn from the inside they short out. Don't talk to me like I'm stupid.
     
  4. sprinklerfitter669

    sprinklerfitter669 Junior Member

    982
    0
    6
    Wow, i cant belive they are not owning up to it

    I hope you get it resolved
     
  5. Redfish-Joe

    Redfish-Joe Senior Member

    2,307
    48
    10
    You seem surprised. :newsmile100:
     
  6. sprinklerfitter669

    sprinklerfitter669 Junior Member

    982
    0
    6
    Yuor right, i meant to say that sarcastically :p
     
  7. Dr.Evil

    Dr.Evil Junior Member

    694
    0
    5
    Have you checked the fuel line going to the starter? if the fuel line bushings are warn this could be the problem. :D
     
  8. Nemick

    Nemick Member

    9
    0
    0
    Redfish, so how do YOU think this happened? Could the bike have been run without it's mufflers or what?
     
  9. Dr.Evil

    Dr.Evil Junior Member

    694
    0
    5
    Just looked at my buddies 09 Road glide. It looks like you could replace the clutch cable without pulling the exhaust. The wires and brake hose are well away from the exhaust and the clutch cable. If they decided to pull the exhaust thy could have used a torch to heat the coupling; one slip would have melted that wire cover. The wires are probably OK but it looks like junk. They should have just admitted what happened.
    Might be in Slidell in a couple of weeks at Textron.
     
  10. Grillfish

    Grillfish Junior Member

    652
    28
    2
    Now that's a good one, Joe. Sorry to hear about the issue. I hope they resolve it for you.

    Ride safe.
    Todd