Used Bike, New Rider, New Vibrations!

Discussion in 'Sportster Models' started by jervic, Jul 16, 2012.

  1. jervic

    jervic New Member

    Need help just bought a used bike from the dealer on the first of june! 03 sportster 883 anniversery special! 5700 miles on it when i got it! Used to be a really smooth ride, now i have 6700 miles on it and it just vibrates all the way from the foot controls up. Started when i was cruising at 70 mph down the highway scared the heck out of me when it first started, then went away for about 10 more miles, then came back again! Now the bike is stuck in a permanent Vibration mode now! Was having some slight problems with the clutch early on lurching ahead on me when starting, and got stuck at a light and couldn't get it into 1st gear so had to take off in 2nd then it hasn't done that since! It seems to make alot of racket now coming from the front end lower side at time's like big clanks! or at least that's where i feel like i'm hearing it at! I also hear alot of hum coming from the chaincase area, checked the fluid level's and chain tension all seem fine, Burnt my hand on the clutch cover plate! Any ideas? could the clutch all of a sudden cause all that vibration or could it be the motor? I Got a 30 day warranty from the dealer but that has just expired a week ago! :(
    Last edited by a moderator: Jul 17, 2012
  2. hogrotten

    hogrotten Junior Member

    Welcome to the forum, it sounds to me like something let go inside the primary, could be a number of things . My advice would be to pick up a service manual for that model and pull the primary cover and do some investigating, if your not comfortable with that you might want to get by a shop and have them take a look before you do any serious damge. Be shure to stop by the new members forum and introduce yourself,also check out the forum rules. :s