Unknown Problem Please Help!

Discussion in 'Electrical' started by dirtyray, Apr 28, 2010.

  1. dirtyray

    dirtyray Member

    9
    0
    0
    I am building a 1998 softail and during the wiring I came across a problem. The left blinker and left light is on as soon as I turn the key. They don't cancel but stay on. What could be the problem and how do I fix it?

    Thanks in advance for any help!
     
  2. Adamal47

    Adamal47 Active Member

    301
    0
    3
    I had a similar problem. I just took apart the left controls and cleaned the contacts really good and it went away.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Look for a pinched wire between the switch housing halves.
     
  4. chester1957

    chester1957 Member

    65
    0
    0
    Could also be a bad switch that is stuck in the on position.
     
  5. dirtyray

    dirtyray Member

    9
    0
    0
    thanks for the help. After searching some more I noticed the wirng on the high side is always on the left blinker does not blink but is always on. I cleaned the connectors and checked for the pinched wires and still no luck the blinker stays on. Could it be something else I am missin like the cancellation switch?
     
  6. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,277
    133
    156
    Are both front and back blinkers on or just the front
    if its just the front may be a problem in the wiring to the front blinker getting power from the other circuit could be a short in the wiring or within the blinker shell

    Brian
     
  7. ultrat

    ultrat Senior Member Contributor

    1,315
    0
    1
    if u have a turn sig module. it may be malfunctioning....?
     
  8. dirtyray

    dirtyray Member

    9
    0
    0
    just hooked the back wiring up and the back worked like it should...so it seems to be just the left front blinker.
     
  9. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    5,277
    133
    156
    That pretty well narrows down your problem area to the wiring to the front left indicator or the bukb fitting inside the indicator shell

    Brian
     
  10. glider

    glider Veteran Member

    25,464
    108
    44
    Possible you have the two circuits in the front light reversed from what you say. The front lights are a double filament (running and directional) and the rears are a single filament (directional only).