turn signals wont turn off.no speedo either.

Discussion in 'Touring Models' started by yousko1949, Apr 13, 2015.

  1. yousko1949

    yousko1949 New Member

    1
    0
    0
    Turn signal module on a 2004 Ultra Classic. Are they under the fuel tank, and if so how do you remove the tank?
     
  2. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    4,388
    103
    404
    I'm not 100% but I believe it's located inside of the fairing.
     
  3. Jack Klarich

    Jack Klarich Guest

    [​IMG]
    Here is your wiring diagram, I would bet it is behind the left side cover
     
  4. stray dog

    stray dog Junior Member

    443
    26
    0
    Are your turn signal flashing and wont go off?
    Your speedo isn't working right either?
    I would be looking at the VSS.
     
  5. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,516
    133
    215
    The turn signal module on my 05 RG was under the seat behind the battery.
     
  6. Breeze3at

    Breeze3at Well-Known Member

    4,851
    83
    181
    My '07 TSSM is just behind the battery also. Inside a silver clip.
     
  7. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,565
    73
    200
    My 03 as well.
     
  8. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    My 03 ultra had same issues. Speedo worked intermittant. At one point speedo would stop working when I had to turn handle bars to the left. Would work when I turned them to the right. All 3 wires to bus were broken just in front of the steering neck.
     
  9. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    I believe the turn signal module uses inputs from the vac (to turn turn signals off after a predetermined distance is traveled or the bike is leaned in a left or right turn.
     
  10. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    From the VSS.