Turn Signal Module

Discussion in 'Sportster Models' started by raymojac, Mar 8, 2016.

  1. raymojac

    raymojac New Member

    The left side turn signal on my 99 sporty works fine but there's an issue with the right side. The front blinker comes on and doesn't blink and the rear doesn't come on at all. The bulbs are good. Could it be a partial failure of the turn signal module or are there any other possibilities? Hope somebody can help. Thanks
  2. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    Trace the wire back to the rear blinker, I believe it runs along the inside of the fender between the fender and tire. I've read the wire can short out and cause a issue like yours. Make sure the bulbs are making a good connection with the socket.
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    Like Jeff said. Start with the back one. Use a test light and check the socket first. If no go, start chasing the wiring down. Chances are it is rubbed under the fender.
  4. fin_676

    fin_676 Experienced Member Staff Member Moderator Contributor

    The wires that run on the under side of the rear fender are a wee bit exposed and can suffer damage
    The turn signal module detects the load drawn and starts to flash only when sufficient power is drawn with only one bulb working on the right side it will come on but not flash
    If you press both turn signal buttons at the same time the hazard warning lights will flash so all 4 flash at the same time even with one bulb dead there is sufficient power drawn to cause the system to flash
    There are small tabs either side of the fender that the wiring sits in pull the tab out slightly and the bundle of wires can be eased out on earlier models of sportster the tail light wiring was also on the right side of the fender

    nakkers likes this.
  5. dbmg

    dbmg Experienced Member

    Have you checked the sockets on the right side for corrosion. Sometimes the button at bottom of socket can stick and not get the power to bulb.
    nakkers likes this.
  6. nakkers

    nakkers Active Member

    With a 99, over time the rear sockets tend to corrode and or the wire frays right around the light post mount inside the fender.