tune up

Discussion in 'Touring Models' started by caseyleiser, May 22, 2011.

  1. caseyleiser

    caseyleiser Active Member

    128
    26
    0
    replaced front motor mount, changed plugs, checked air filter, bike still seems to idle rough. Took it to the dealer, they say it needs a tune up. I asked them what that consists of, other than what I had done. They say it needs a couple of dyno runs to see what it needs. Is this true, I can,t see it myself. The bike is an 05 ultra, 103 motor s.e. air filter, monster mufflers and power commander. I think my p.c. might be shot. Anything else I can check before replacing p.c.? thanks for any help.:help:help
     
  2. Chopper

    Chopper Senior Member

    1,632
    48
    18
    Is the rough idle the same with a hot or cold engine? Have you checked for a intake manifold leak? Don't see how the dyno will really help diagnose a idle problem.
     
  3. glider

    glider Veteran Member

    25,464
    108
    44
    Being you changed the mount, you'll find that the new mounts will transmit more vibrations to the bike at idle than the older one did. You already changed the tune up parts so I would be a bit reserved about the dyno runs they want to sell you. They don't come cheap and you should be able to tell if the bike is lacking power or not.

    How did they determine it needs a tune up being you just did one and what makes you think the PC is shot? Have you thought about just disconnecting the PC and give it a run?
     
  4. caseyleiser

    caseyleiser Active Member

    128
    26
    0
    I think the dealer just wants to sell a dyno test to anyone that bites, I followed dynojets instructions but when I push the rich and lean buttons on the p.c. the l.e.d. lights don,t change.Makes me believe it might be shot. The plugs show that it,s running a bit lean. I,ll try unplugging it and see what happens. I f I need a new one, the tfi sounds like an inexpensive easy way to go. I,ll let you know. Plus how can I donate, I don,t have paypal.
     
  5. caseyleiser

    caseyleiser Active Member

    128
    26
    0
    thanks for your reply Chopper, bike seems to run rougher when warm. I,ll check for manifold leaks.
     
  6. BUBBIE

    BUBBIE Well-Known Member

    4,959
    83
    113
    ***********************************

    When and IF you go TFI or Gen3, Don't forget the Discounts... Check them out BEFORE you order..

    signed....BUBBIE
     
  7. caseyleiser

    caseyleiser Active Member

    128
    26
    0
    Thanks Bubbie, looks like I might do that Ijust went for a ride with my p.c.111 taken off. No difference in the motor at all. I,ll try cleaning the connections, see if thsat does anything.
     
  8. 03ultra45385

    03ultra45385 Active Member

    146
    28
    3
    This a little different cause for a rough idle. My compensator nut came loose and it wasn't till after the extended warranty was up that I actually found it when replacing the primary chain and adjuster. The difference in the idle before and after was encredible. The compensator was really loose and the clutch/flywheel weren't working with the engine to help keep it idling as smooth as it should have.
     
  9. flh canuck

    flh canuck Active Member

    215
    28
    2
    A dyno run wouldn`t hurt anything but if the issue is only at idle then a dyno run may not be necessary. Just a few questions:

    How long have you owned the motorcycle?

    How many miles on the engine?

    Does the engine sound like it is mis-firing or is it just jumping around alot in the frame?

    Did the rough idle start all of a sudden or has it been a gradual development?

    Is there any engine hesitation when you open the throttle off idle?

    Is there any difference warm or cold?

    Did the rough idle start after changing any components or doing any performance mods?

    Are there any issues with roughness or mis-firing from the engine or performance issues when in gear and cruising or accelerating?
     
  10. caseyleiser

    caseyleiser Active Member

    128
    26
    0
    Hi FLH Canuck. Good name, go canucks. I got the bike about 5 years ago, it has 62000 kms. on it. The rough idle seems worsr when it,s warm, feels like the injectors may be dirty. Runs fine at speed, once in a while there,s a little hesitation when taking off. If I,m idling along in heavy traffic I have to use the clutch more to stop the lurching if that makes any sense to you. No recent mods done to it.