TSSM issue

Discussion in 'Electrical' started by 05roadglide, Nov 21, 2009.

  1. 05roadglide

    05roadglide New Member

    1
    0
    0
    recently experienced a failure of my speedo, tach, turn signals and my security light was on constantly indicating a fault. Went to the local dealer and recounted my symptoms and was told that the TSSM was the culprit. $232 later and the problem was not corrected. (turned out to be the accessory fuse....I learned this after searching the forums on a couple of sites).

    I have been told that since the TSSM unit was installed and married to the bike that they cannot reuse the item on another bike. I find this hard to believe as I have read where others have purchased one on ebay and installed.

    At this point I have little faith in the information given to me by this dealer..does anyone know if the unit is in fact no longer usable by another bike....
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
  3. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Since the dealership diagnosed the problem, even if they will not take the part back you should not have to pay for it. If this was an authorized HD dealer a call to the MOCO would be the first thing I would do, and if the dealer is still unresponsive a letter to the dealer and the Better Business Bureau and your local District Atty. should get their attention.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    Excellent point Don. If it didn't fix the problem, you shouldn't have to "buy" the unit because of their mistake.