Trouble with new ride?

Discussion in 'Touring Models' started by tande, Dec 23, 2008.

  1. tande

    tande Member

    5
    11
    0
    I have an 08 FLHTCU with 14k miles it has run great until now.I was on my way home from work and it backfired then got real sluggish I could only go about 60 mph in 6th @ 3k rpm could it be a fuel filter? I just had 10k service done and it has been running great.
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Could be a number of things like bad gas or water in the gas but if you just had the service done, I would let the dealer take it back and find/eliminate the problem. Either way if they did something wrong or otherwise it's under warranty.
     
  3. Harley Hog

    Harley Hog New Member

    1
    11
    0
    It is your fuel canopy. You should have gotten a recall letter from Harley. Same thing happeded to me. It will get worse real fast. I suggest you get it to the dealer ASAP. It is under warranty.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
  5. NEWHD74FAN

    NEWHD74FAN Experienced Member Retired Moderators

    8,176
    98
    16
  6. tande

    tande Member

    5
    11
    0
    I called the dealer and they said I didn't have any recalls. I started the bike today and it ran fine that is why I called the dealer I wanted to make sure it was safe to ride .I am taking it in tomorrow besides I need a new back tire they think I might have an ECM problem and its under warranty.thanks for the help. P.S keep it on two wheels and have a merry Christmas.
     
  7. glider

    glider Veteran Member

    25,464
    108
    44
    Did you try your VIN in this link?

    https://www.harley-davidson.com/EX/M...bmLocale=en_US
     
  8. R. Lewis

    R. Lewis Senior Member Retired Moderators

    2,183
    48
    5
    DOUBLE CHECK anything the dealer tells you!!!
     
  9. tande

    tande Member

    5
    11
    0
    I just checked it I didn't see any recalls but it showed service schedules.
     
  10. glider

    glider Veteran Member

    25,464
    108
    44
    Check your production date also on the bike.

    Rumor has it the MOCO has been using the upgraded part in assembly since January....the 07 build dates are the ones with the defective part up to 12/07