Trouble with Diagnostic codes

Discussion in 'Electrical' started by LVspringer, Aug 20, 2008.

  1. LVspringer

    LVspringer Member

    25
    11
    0
    Hello,

    I have a 2006 FLSTSC-I and have spent the past several months customizing it but am now having some problems that I attribute to my lack of ability in wiring. I added longer, wider handlebars so had to replace the handlebar switches on both sides. I used the appropriatre Deustch connectors and crimp tool and followed the wire color coding. I also added passing lamps and the retro style horn. I relocated the front turn signals and re-wired both front and rear.

    I am running the diagnostics and come up with the following information:

    P (Electronic Ignition) No Response
    S (Turn Signal Security Monitor) Code 61121 and then the word "END" and then it flashes PN 68923-00d
    SP (Speedometer) None and then it flashes PN 67033-04A
    T (Tachometer) No Response

    Even though my turn signals so not appear to be working correctly, they do flash appropriately when I arm and disarm the security system. Since I removed the battery, I also used the master reset (On-Off-On-Off-On and pressed the left turn signal and got the expected flashes. However, my red security system "Key" icon remains lighted.

    I've got nothing when I hit the starter so I think the security system is still set to on.

    Any ideas and help would be greatly appreciated. I've been working on this custom for months now and want to ride :)
     
  2. glider

    glider Veteran Member

    25,464
    108
    43
  3. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    did you have your "kill" switch set to run when you checked the codes. If you don't you will get no response from the ecm. If you did have it set to run when you checked the codes and still got no response that may be a reason for your no start condition.
    I don't see the code you mentioned on the list. Are you sure of the number?
     
  4. LVspringer

    LVspringer Member

    25
    11
    0
    Thanks! Yes, I had the kill switch in the "off" or "run" position bt on second look, the error code I got was b1121 (the b looked like a 6). I am still getting a No Response for the ECM/ICM check and the b1121 under the TSM/TSSM. No other codes are coming up. I did get my security system to turn off and going through the master re-set and then turning it off with the fob. I think one or more of my connections from the handlebar switches may not be right. I'd really like to know what that code means (b1121) since it does not appear on the list Glider provided. I will keep trouble shooting.

    Again, thanks!

    LVSpringer

    Pictures of the project can be seen here The
     
    Last edited: Aug 20, 2008
  5. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    so your saying you had it in the "run" position and still got the no rsp when you went to diagnostic mode?
     
  6. LVspringer

    LVspringer Member

    25
    11
    0
    Thanks! I went through it again and the code I'm getting appears to be b1121 (thought the b was a 6). No Response still coming up on the ECM/ICM Check but no other codes.

    Thanks!

    LVSpringer
     
  7. LVspringer

    LVspringer Member

    25
    11
    0
    Yes, perhaps that means that the kill switch wire is not making a good connection inside of the connector.

    LVSpringer
     
  8. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    could be, and I've also seen where a wire didn't "latch" when it was put back into to the wire harness and it got pushed back when the harnesses were plugged in. Might be something that simple, but that code I don't know. You should be able to call the service dept. of any dealership and tell the numeric trouble code and they should be able to tell you what it means. The dealership here will, anyway if yours won't, call Shumate in Spokane at 509-928-6811. Ask for service and tell them the code. If they have an answer they'll give it to you, and I've never been on hold very long with them.
     
  9. glider

    glider Veteran Member

    25,464
    108
    43
    B1121(TSM) Left Turn Output Fault
    B1121(HFSM) Left Turn Output Open
     
  10. wildspirit97

    wildspirit97 Senior Member

    1,088
    46
    0
    WOW! Your pretty good, I couldn't find that anywhere, guess I'll have to pencil that one in on my list.:s