trike motor " ping "

Discussion in 'Trikes' started by colotriglide, May 11, 2010.

  1. colotriglide

    colotriglide New Member

    I have a 2009 triglide, since new it pings after getting warm. Have been to several dealers and left it for days. No one has been able to repair or tell me a fix for this. Has anyone else had this problem with their triglide.
  2. Boom

    Boom Member

    This is a first I've heard this happening on any TG. I would figure more on the '10s because they run hotter with the catalyst in the headpipe. I assume you are running 93 octane?
    If you aren't getting results from the dealers, call the MoCo and complain. Or, look into a fuel managemnt device such as PC V or TTS Mastertune.
  3. Gator454

    Gator454 Active Member

    Premium Fuel Only
  4. Timman

    Timman Member

    I had a ping develop on my 09FLHRC about 2 months after I bought it last summer, I was thinking I got a bad batch of gas so I tried new plugs and some octane boost but it was still there until I did a stage one, (SE air kit, VH monster ovals, and a TFI). I also fell that I was lugging the bike too much and had to learn to drop it down a gear and let it wine a little more when needed.
  5. Hoople

    Hoople Account Removed

    When you say it pings, I assume you mean engine knock. Under what conditions are you hearing the knock? Hard acceleration from 2500 and up? If you are experiencing knock, you should only hear it for 2-3 power strokes and then it should fade away if the ion-sensor is working properly.

    The '09s and '10's have a Crazy amount of spark advance written into the stock spark advance table during 35%-70% of engine load. The map RELIES on the ion-sensor working and kicking back the timing. The advance is pushed for fuel economy and cleaner exhaust. No engine could handle the programmed amount of advance without a knock retard system.

    Does your engine only knock for a few hits or does it continuously knock.
  6. colotriglide

    colotriglide New Member

    Run premium fuel all the time plus additive 108+ Ping is on a cruise condition, not under load. Even with cruise control on. We have talked about changing pipes and air filter with new download but think this is just masking the problem and not repairing the problem. I am still keeping in touch with harley tech and they are working on it but was hoping someone has had or has this problem and with everybody putting their head together we can come up with a solution.
  7. Hoople

    Hoople Account Removed

    That is crazy. Are you absolutely sure what your hearing is in-fact engine knock.

    Octane Boost,, at cruise speed with no engine load,, Ion-sensor spark retard system.. Can't believe the engine knocks under these conditions.

    Your compression would have to be greater than 200 PSI or your head temperature would have to off the charts.
  8. Breeze3at

    Breeze3at Well-Known Member

    Sounds like you have a rattle somewhere. A constant detonation at cruise speeds would more than likely have lunched the engine by now. Like Hoople said, too many sensors involved to be det.
  9. iteachit2u2

    iteachit2u2 Member

    I think I know what "ping" you are talking about... mine did it and then I tried this; (sorry, cant post links yet so here is a copy)

    Automatic Chain Tensioner Adjustment
    Published by glider (Community Liaison)
    Published date: May 20th, 2008

    Here's a trick to reduce the constant engine noise that sounds like valve train noises on the newer 96 Cu In. bikes that have the auto adjusting primary chain tensioners and no inspection port.
    I tried this on my RKC and can notice a definite improvement. The problem seems to be coming from the primary chain and not really the valve train at all.

    Here's what you do. Accelerate from a stop in first gear rather hard to about 30 MPH and then brake rather hard using only the rear brake without locking up the wheel and don't pull in the clutch until the bike slows enough.
    Do this 2-3 times in succession and you'll notice that the noise that you thought was the valve train is almost completely gone now. Low speed riding is a bit smoother also due to less play in the chain.

    By doing this, the automatic primary chain will ratchet up a bit tighter if it was loose before this. The acceleration and braking causes slack in the lower strand of the chain and will ratchet it up tighter if it needed an adjustment.

    If it wasn't loose there will be no noted difference.
    That is most likely the noise that was heard and not the valve train at all.

    Sounds strange but try it!
  10. trike lady

    trike lady Junior Member

    Last edited by a moderator: Sep 12, 2010