throttle issue

Discussion in 'Touring Models' started by revok1200, Mar 15, 2013.

  1. revok1200

    revok1200 Active Member

    209
    28
    2
    my friends electraglide is Throttle By Wire. Yesterday while riding the check engine light came on and he lost the throttle. Bike never shut down, just no throttle. Pulled over, restarted the bike, all good, went a few hundred yards same deal. Restarted again, took off, no problems?

    Any ideas?
     
  2. HDDon

    HDDon Experienced Member Contributor Retired Moderators

    5,456
    133
    196
    Has your friend checked to see if there are any codes? My first guess would be the throttle twist grip sensor.
     
  3. Jack Klarich

    Jack Klarich Expert Member

    18,544
    153
    399
    http://www.hdtalking.com/archive/t-2362.html Start here
     
  4. bc45

    bc45 Active Member

    211
    0
    1
    Check for codes like Jack said, there is a TSB for I belive p2135 code. they had some problems with a bad connection at the throttle body motor plug. if thats the case unplug it make shure it is clean and put dielectric grease in the plug.
     
  5. redbarron425

    redbarron425 New Member

    1
    0
    0
    My wifes 2011 ultra three wheeler did the same thing last night. It is showing a code P 1511 and P 2101.
    She started the bike up and it was in high idle and had no throttle at all. She killed it and restarted and was fine on the way home. About six blocks.
    Will ride again Sat. and see if it does it again.