Throttle Is Not Closing

Discussion in 'Touring Models' started by RottMan, Oct 30, 2008.

  1. RottMan

    RottMan Member

    53
    16
    0
    On my 09 SG I'm noticing that when I release the throttle it doesn't roll all the way back to the closed position. I have to manually rotate it back the last bit which drops the RPMs down from about 1100 to 900. Also, when I got off the bike this morning at work, I twisted the throttle open and it didn't close at all. Now the bike was off at this time so I don't know if that has anything to do with it, but it does seem strange and the fact that it doesn't completely close when I'm riding concerns me. I know nothing about the new "by wire" throttle. Any thoughts?
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    If you have changed the grips, this may be part of the problem, otherwise take it back to the dealer for the proper documentation and repair before you get injured.
     
  3. RottMan

    RottMan Member

    53
    16
    0
    I haven't changed the grips. I was hoping to hold off till my 1K service, which will be soon as I'm at 800 miles already, but it looks like I'm gonna have to make two trips to the dealer now.
     
  4. glider

    glider Veteran Member

    25,464
    108
    44
    The difference between 800 and 1000, you can have the service done now too.:s
     
  5. RottMan

    RottMan Member

    53
    16
    0
    Point well taken. Thanks.:bigsmiley12:
     
  6. RottMan

    RottMan Member

    53
    16
    0
    Congrats! Lets see some pics!
     
  7. RottMan

    RottMan Member

    53
    16
    0
    For anyone interested....got a call from the dealer today. Bike is ready to go. Issue was simple...loosened the 2 screws on the switch housing and adjusted out the grip a bit...all better. :s