TFI Rubber Plug Replacement Needed

Discussion in 'TFI Questions Answered By Dobeck' started by RibEye, Apr 8, 2011.

  1. RibEye

    RibEye Junior Member Contributor

    973
    48
    45
    Unfortunately, during operations performed by the dealer, to try to diagnose a problem not related tot he TFI, the rubber plug that covers the pots was lost. I do not see a parts list in the TFI documentation, nor a parts purchasing area in your web site. How can I purchse a new plug?

    Thanks,
    Rich P
     
  2. DobeckTechSupport

    DobeckTechSupport Active Member Product Contributor

    149
    28
    2
  3. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Another reason why Dobeck's highly recommended on this forum - awesome support! Love my TFI!!!
     
  4. sharpscuba

    sharpscuba Banned

    945
    0
    1
    Ditto on the support. From the time that I made my first call I have never been disapointed. Keep up the great work.
     
  5. cromedome

    cromedome Active Member

    264
    0
    3
    Just ordered one, they sent the wrong one, many apoligies on their end, the right one is already one the way, everyone makes mistakes, it's how they deal with them that counts..
     
  6. RibEye

    RibEye Junior Member Contributor

    973
    48
    45
    Thank you very much for your quick response. Email sent.

    Enjoy,
    Rich P
     
  7. cyborg

    cyborg Active Member

    242
    28
    1
    I don`t know what happened but my rubber plug is missing also..
     
  8. RibEye

    RibEye Junior Member Contributor

    973
    48
    45
    Just an update...

    I sent the specified email, and Dallas at Dobeck got the right one in the mail toot sweet. I have received it and installed it.

    Thanks Dallas and Dobeck. You guys are among the very best.

    Enjoy,
    Rich P