TFI may have Reset to defaults by itself

Discussion in 'TFI Questions Answered By Dobeck' started by SuperGlides, Apr 12, 2015.

  1. SuperGlides

    SuperGlides New Member

    1
    0
    0
    Hi,

    I have a 2009 Sporty with basically a stage 1 kit and a GEN3 TFI.

    I have not ridden the bike for about 8 days (it sat under cover out the back and was not connected to a trickle charger) and today was the first day I have ridden it into work. It started okay, but after a few miles it developed the old engine miss that i had prior to installing the GEN 3 - when moving if the throttle is held 'just' open a bit - like when in a steady cruise on the free-way at say 50mph (although the actual speed is irrelevant).

    Anyway...my question is: Could the unit somehow have forgotten my adjustments (which are the recommended stage 1 settings). It almost like there is a small battery inside the unit that stores the changes I have made and somehow its gone flat and things have reset back to default - I assume the base settings are basically on an EEPROM so they will always be there.

    Regards
    Graeme
     
  2. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,596
    103
    296
    The settings will not change on there own. Unless you ordered it with different settings it will be factory set for stage 1 and with a exhaust change.
     
  3. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,596
    103
    296
    If it was running good on your last ride I'd start with the basics. How old is the battery? check and clean all battery connections, check spark plug boots, make sure they are tight, are you running fresh fuel? Try running an oz or 2 of seafoam to a full tank of gas, it may just need a good cleaning. Unless you changed the factory setting on your gen3 they will still have the settings sent from the factory.
     
  4. DobeckTechSupport

    DobeckTechSupport Active Member Product Contributor

    149
    28
    2
    SuperGlides,

    The Gen 3 should not lose its settings. It is designed to retain its settings. Even if you were to completely remove the Gen 3 and reinstall it, the controller will keep the last saved settings.

    I have heard instances of settings getting changed because the controller was in a place where the buttons could get pushed under the seat.

    Also check and make sure the controller is functioning properly and the ground is connected. If the ground is disconnected or if the wire is broken, the controller will not function and the bike will return to stock.

    Does the controller light up when the bike is turned on?

    --TuningHQ