TFI 2nd Gen - Adjustment screw settings

Discussion in 'TFI Questions Answered By Dobeck' started by aclewer, Aug 13, 2010.

  1. aclewer

    aclewer Member

    6
    11
    0
    I just received shipment of a TFI 2nd Generation for a 07 Street Glide (Model FI-1250ST) My bike is stock for now (no aftermarket air or slip-ons).

    It was my understanding that when the TFI is shipped, all the settings are set for an "all stock" application...like my situation. Just plug it in and ride.

    However, when I looked at the control unit's screw settings they don't match the settings for "All stock" listed and illustrated in the back of the instruction sheet.

    That is, the control unit shows: G 1;Y 1; R 1; RPM 6.

    Whereas, the settings on the instructuction sheet shows:
    G 2.5; Y 3; R 2.5; RPM 4.

    I'm confused. What settings do I go with?

    Thanks in advance.
     
  2. ultrat

    ultrat Senior Member Contributor

    1,315
    0
    1
    use inst. sheet & tweek from there. when set on 1 its off.... & welcome.... i have tfi also..
     
  3. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    aclewer; I'm sure Dobeck will chime in here, but if you're planning to install soon just select the settings for your bike's config. Intall sheet should show pot settings for typical UG's & then you're gonna "fine tune" from there so give it a try & tell us how things worked out. Good luck & you're gonna love the tuner - best $$$ spent on my scoot to date.
     
  4. aclewer

    aclewer Member

    6
    11
    0
    Thanks Ultrat and Iceman24. I'll be doing the instal in the next few days.
     
  5. ultrat

    ultrat Senior Member Contributor

    1,315
    0
    1
    as far as wires allow. i taped my tfi on tank & would make it easer to adj, glance down at leds. see when it was changing. i moved my #4 pot just under 4 so main jet setting come on a little sooner.
     
  6. aclewer

    aclewer Member

    6
    11
    0
    Install complete....the difference is night and day!!!!

    All the old symptoms are gone...especially at idle. Now I can pull up to a stop light and not worry whether I'm going to stall out ! No decel popping either.

    I can't believe that I put up with a poorly running bike for 3 years.

    Highly recommend.
     
  7. Iceman24

    Iceman24 Well-Known Member

    3,224
    48
    13
    Glad to hear it - funny what a little "computer chip intervention" does to your engine. Where did you end up mounting the box? I put mine in Left or Right side panel (can never remember) where ABS should go (if I had it). Now you're ready for the next upgrade...;-)
     
  8. DobeckTechSupport

    DobeckTechSupport Active Member Product Contributor

    149
    28
    2
    aclewer,

    Appears everything is going good for you, but to answer your original question for all the forum readers only our GEN3 controllers come pre-programmed for a stage 1 setup. The GEN2 TFI pots are usually set to be off (1:00) which is running stock fuel not suggested stock settings. The TFI always needs to have the pot settings checked to verify the settings before your first ride.

    Hope you're enjoying your bike rides with a whole new feel.