Tach needle jumping and not working

Discussion in 'Touring Models' started by BJF316, May 30, 2011.

  1. BJF316

    BJF316 New Member

    Just had the stator replaced in my 2003 FLHT this past week. I rode Friday and Saturday without any problems, but yesterday I got about 5 miles into my ride and I noticed the tach needle bounced from 2200 up to 3000 real quick and return back to 2200. It did this several times and then quit working. It quit working for just a few seconds and then began working normal again for a short while and then bounced up and back a few times and stopped working again. I turned around and headed home. After getting home, I left the bike running while I opened the garage door, and the tach started working again. The volt gauge kept a constant reading of 15 or 16 the whole time I was riding and bike started and ran fine the whole time. The Indy also overhauled the starter when he replaced the stator. He had just completed a 95 inch build on my engine and noticed my starter was starting to drag a bit. I'm not real knowledgeable on electrical systems or anything, so any help would be greatly appreciated. Gonna get with the Indy tomorrow, but hoping to get a idea what might be causing the problem before hand. Hopefully nothing to bad. Thanks for any help, B.J.
  2. glider

    glider Veteran Member

    Your voltage reading of 15-16 is high assuming the gauge is correct. You may want to verify that voltage with a meter at the battery before going any further.
  3. ElectraRob

    ElectraRob Banned

    Does your Odometer go all gray? do your lights get really bright when this happens? Mine did the same thing. installed a new Voltage regulater, it fixed it. you should have the 50 amp main breaker in there by now. easy way to tell is if it is red or pink, its the 40 Amp. the 50 Amp is black.