Switch troubles?

Discussion in 'Touring Models' started by locodude, May 10, 2009.

  1. locodude

    locodude Member

    20
    11
    0
    I've got a problem. Recently I stopped at a store and came out and my bike wouldn't start except in neutral and the little green 6 only comes on sometimes and the cruise works only occassionally also my security light is on almost continuously. I've been told that there is a clutch switch in one of the housings that is causing my problems. Has anyone here had a similar experience and if so what was the fix? BTW it's a brand new 09 ultra classic electra glide
     
  2. glider

    glider Veteran Member

    25,464
    108
    44
    Your problem could be the clutch switch in the housing or the neutral switch. If the bike starts in gear without pulling in the clutch handle, it's probably the neutral switch ion the trans.

    Pull the codes and see what they tell you. It should point you in the right direction. With the security light on ALMOST continuously, it isn't a steady fault probably so that points to the neutral switch more than the clutch switch. Does the neutral light come on while riding and the bike is in gear?

    09-08-07 DTC Codes - Harley Davidson Community
     
  3. locodude

    locodude Member

    20
    11
    0
    no the neutral light does'nt come on while riding and the bike will be going back to dealer.....again next week. I must say out of 3000 miles almost 500 has been to take it back to dealer for little things going wrong with it I'm starting to wonder if I purchased a dream machine or a nightmare.