Sticking Throttle

Discussion in 'Other Service and Maintenance' started by sampson80, Oct 24, 2012.

  1. sampson80

    sampson80 Member

    42
    0
    0
    Throttle is only sticking when the wheel is full right. I have loosened the throttle and readjusted, lubed the cable, and it still sticks and full right. Snaps back perfectly when left and center. I'm out of ideas. Anyone have any suggestions??
     
  2. lordharold

    lordharold Active Member

    191
    0
    2
    you might try while it is full right loosening the idle cable until it snaps back
     
  3. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,310
    73
    130
    Lordharold has a good suggestion. See if you can adjust it while full right to make it snap back.

    If you remove the cable completely and lube it real good and hang it overnight so the lube works all the way threw it may help

    Does it have stock bars on it? If not, you may have a cable stretched just a bit too far and it wont adjust out. Maybe check the routing and see if you can straighten it out some how. It also could mean that its just time for new cables.
     
  4. Jeff Klarich

    Jeff Klarich Well-Known Member Contributor

    3,596
    103
    296
    There is not to many things that would cause your problem. Bodeen hit the nail on the head with his post.
     
  5. RibEye

    RibEye Junior Member Contributor

    973
    48
    44
    If there are no bends too sharp, you may have a frayed cable. Sticking cables of any kind are nothing to allow to exist.

    Good luck,
    Rich P
     
  6. sampson80

    sampson80 Member

    42
    0
    0
    Will try to adjust the cable at full right and see what happens. Still has stock bars so nothing has been modified that would cause a strain. I also haven't readjusted the idle cable, I didn't think it would have anything to do with the throttle sticking but I will readjust that also and see. Thanks for the suggestions, just wanted to make sure I wasn't missing something simple
     
  7. Bodeen

    Bodeen Well-Known Member Staff Member Moderator Contributor

    4,310
    73
    130
    Both cables need adjusting. I think you will find that to be your problem.